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Automatic and manual backups of the View Connection Server database fail (2040602)
Symptoms
- Automatic backups of the View Connection Server database fail
- Manually backing up the View Connection Server database in the View Admin console (View Configuration > Servers > Connection Servers > Backup Now... ) fails
- Changing the data recovery password in the View Admin console (View Configuration > Servers > Connection Servers > Edit Backup > Change data recovery password) fails with the error:
Internal Error
- In the machine where the View Connection Server is installed, backing up the ADAM database via vdmexport as per Performing an end-to-end backup and restore for View Manager (1008046) is successful.
- The View Connection Server logs may contain entries similar to:
DEBUG (15C0-1788) <6024> [vdmexport] MessageFrameWork Worker Shutdown, Name=admin, Channel=0000000000000000
WARN (0784-0AD0) <2768> [ws_ldap] LDAP Backup Service LDAP Backup to C:\ProgramData\VMware\VDM\backups failed - exit status 1
WARN (0784-0AD0) <2768> [ws_ldap] LDAP Backup Service failed to backup LDAP data to C:\ProgramData\VMware\VDM\backups\Backup-20121128111043.LDF - file is zero length
ERROR (0784-0AD0) <2768> [ws_ldap] LDAP Backup failed - system error from command execution (1)
Note: For more information on the location of the View log files, see Location of VMware View log files (1027744).
Cause
This issue may occur if the permissions on these folders are incorrect:
- C:\ProgramData\Microsoft\Crypto\RSA\S-1-5-18
- C:\ProgramData\Microsoft\Crypto\RSA\MachineKeys
Resolution
To resolve this issue, ensure that these folders' NT AUTHORITY\SYSTEM account has Full control permissions enabled:
- Right-click the folder C:\ProgramData\Microsoft\Crypto\RSA\S-1-5-18, click the Security tab, and check that the NT AUTHORITY\SYSTEM account has Full control set to Allow.
If not, edit the permissions for this account and set Full control to Allow.
- Right-click the folder C:\ProgramData\Microsoft\Crypto\RSA\MachineKeys, click the Security tab, and check that the NT AUTHORITY\SYSTEM account has Full control set to Allow.
If not, edit the permissions for this account and set Full control to Allow.
See Also
Request a Product Feature
To request a new product feature or to provide feedback on a VMware product, please visit the Request a Product Feature page.
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