Knowledge Base

The VMware Knowledge Base provides support solutions, error messages and troubleshooting guides
 
Search the VMware Knowledge Base (KB)   View by Article ID
 

GemFire 6.6.3 compatibility issues with GemFire 7.0 (2039980)

Symptoms

GemFire 6.6.3 clients fail to log on to GemFire 7.0 servers

Cause

Backward compatibility in GemFire allows clients running older versions of GemFire to connect to servers running newer versions of GemFire. The same functionality also allows two different distributed systems running different versions over the WAN to talk to each other. Backward compatibility also allows you to upgrade different elements of a system at different rates. For example, GemFire 5.7 clients can talk to GemFire 6.6 servers alongside GemFire 6.6 clients connected to the same cluster.

In GemFire 7.0, a bug was discovered that prevents 6.6.3 clients from being able to talk to 7.0 servers.

Resolution

This is a known issue affecting GemFire 6.6.3 and earlier clients connecting to server clusters running GemFire 7.0.

To resolve this issue, you must upgrade all 6.6.3 and earlier clients to 6.6.4 if you wish to connect those clients to a server cluster running GemFire 7.0.

If your server cluster is running GemFire 6.6.x and you are thinking of upgrading to 7.0, perform this workaround:

  1. Download VMware vFabric GemFire 6.6.4 from the VMware Download Center or request the GemFire 6.6.3.5 hotfix from VMware Technical Support.
  2. Shut down each pre-6.6.4 GemFire server, one server at a time, and install GemFire 6.6.4 into the previous 6.6.x installation directory, then restart the server.

    Note: Since GemFire 6.6.4 is a minor update, you can perform a rolling upgrade by upgrading each server one at a time, thus avoiding downtime for the entire server cluster.

  3. Ensure that you start up the final server with the --rebalance option so that the cluster data stays load balanced.
  4. Shut down all clients, install the GemFire 6.6.4 client, then restart the clients.

    Upgrading to 6.6.4 ensures that if you wish to keep your clients at version 6.6, you will not need to modify your clients when you upgrade your servers to GemFire 7.0.

Note: Upgrading the servers from GemFire 6.6.x to 7.0 requires that you shut down the entire cluster at the same time. Follow the upgrade instructions provided in the vFabric GemFire User's Guide to upgrade to the new version.

Request a Product Feature

To request a new product feature or to provide feedback on a VMware product, please visit the Request a Product Feature page.

Feedback

  • 1 Ratings

Did this article help you?
This article resolved my issue.
This article did not resolve my issue.
This article helped but additional information was required to resolve my issue.
What can we do to improve this information? (4000 or fewer characters)
  • 1 Ratings
Actions
KB: