Knowledge Base

The VMware Knowledge Base provides support solutions, error messages and troubleshooting guides
 
Search the VMware Knowledge Base (KB)   View by Article ID
 

Upgrading to vShield Edge 5.1.x fails with the error: Failed to upgrade Niobe VSE to SPOCK gateway (2039554)

Symptoms

  • When upgrading the vShield Edge device from 5.0.x to 5.1.x, the upgrade task in the vCenter Recent Tasks pane fails
  • The new vShield Edge device is powered down and deleted, and the old device is reverted
  • The vShield Manager log contains entries similar to:

    “Info 2012-11-06 15:39:12.212 GMT *** *** 22: Updating the new edge 'edge-9' with all feature configurations for network 'dvportgroup-4473'
    Error 2012-11-06 15:39:13.419 GMT *** *** 22: Failed to upgrade Niobe VSE to SPOCK gateway
    com.vmware.vshield.edge.exception.VshieldEdgeException: 
    vShield Edge:13003:[StaticRouting] Invalid nextHop '172.16.3.71'. NextHop must not be a Vnic assigned IP Address.:null, 
    vShield Edge:13004:[StaticRouting] Invalid network '172.16.3.201/32'. It overlaps with be a Vnic assigned IP Address.:null”

Cause

When trying to upgrade the vShield Edge device, the installation is finding a static route in the configuration of the existing device, which conflicts with the network settings for the vNIC.

Resolution

To resolve this issue, remove the static route from the configuration of the existing vShield Edge device, then retry the upgrade.

Request a Product Feature

To request a new product feature or to provide feedback on a VMware product, please visit the Request a Product Feature page.

Feedback

  • 0 Ratings

Did this article help you?
This article resolved my issue.
This article did not resolve my issue.
This article helped but additional information was required to resolve my issue.
What can we do to improve this information? (4000 or fewer characters)
  • 0 Ratings
Actions
KB: