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Connecting to a View Desktop using PCoIP fails with a black screen (2039529)

Symptoms

  • Cannot connect to a View desktop using PCoIP.
  • Connecting to a View desktop using PCoIP fails with a black screen.
  • You have installed VMware Tools and View Agent in the correct order as per Configuring PCoIP for use with View Manager (1018158).
  • The VMware SVGA 3D driver properties show driver version 7.14.1207.

    Note: To check the version of the VMware SVGA 3D driver:
    1. Log in to the View desktop.
    2. Right-click My Computer and click Manage.
    3. Click Device Manager.
    4. Expand Display adapters.
    5. Right-click the VMware SVGA 3D driver and click Properties.
    6. Click the Driver tab.

Cause

This issue occurs when the View 5.1 Agent is installed on a virtual machine on which VMware Tools for ESXi 5.1 (managed by vSphere 5.1) is installed. In this case, the driver does not get replaced with a proper PCoIP compliant driver.

This issue may also occur if the View desktop is running an older version of VMware Tools.

Resolution

To resolve this issue, reinstall VMware Tools and View Agent, so that the correct VMware SVGA driver gets installed.
 
To reinstall VMware Tools and View Agent:
  1. Uninstall VMware Tools and View Agent software on the View desktop and reboot the VM.
  2. Install the VMware Tools in Custom mode. For more information, see Installing VMware Tools in vSphere (2004754).
  3. Expand VMware Device Drivers and change the SVGA Driver to This feature will not be available and reboot.
  4. Install VMware Tools and reboot.
  5. Install the View Agent and reboot. For more information, see the Install View Agent on a Virtual Machine section of the View 5.1 Administration Guide.
  6. Verify that the correct version of the video driver is installed. For more information, see the Additional Information section of The PCoIP server log reports the error: Error attaching to SVGADevTap, error 4000: EscapeFailed (1029706).

    You should now be able to connect to View desktops via PCoIP.

Additional Information

See Also

Update History

01/28/2013 - added "managed by vSphere 5.1" in the Cause section. 04/28/2013 - Added the "reboot" after each recommended install or uninstall in the resolution section.

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