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Unable to login to the vCenter Operations Manager 5.x Custom UI (2036516)

Symptoms

  • When attempting to login to the Custom UI https://<IP address of UI virtual machine>/custom, an error message similar to the following is displayed:
Could not determine licensed VC
  • Error messages similar to the following may be present in the /var/log/vmware-vcops/user/log/web.log file on the UI virtual machine:

2012-09-24 03:42:18,082 ERROR [RMI TCP Connection(7476)-172.20.20.2] org.hibernate.util.JDBCExceptionReporter.logExceptions - Cannot get a connection, pool error Timeout waiting for idle object

  • There are numerous users connection to the Custom UI at any point in time.
  • There are a large number of widgets configured and accessed in the Custom UI.

Cause

By default, only 45 connections are allowed between the tomcat process responsible for the Custom UI and the postgres database on the Analytics virtual machine. If this number is exceeded, the Custom UI will be inaccessible.

Resolution

The maximum number of connections between the tomcat process responsible for the Custom UI and the postgres database on the Analytics virtual machine can be increased via the following process: 
  1. Log in to the UI virtual machine as root.
  2. Issue the following command to stop the Custom UI:

    service vcopswebenterprise stop

  3. Run this command to delete the backup of the relevant configuration file:

    rm $ALIVE_BASE/tomcat-enterprise/conf/Catalina/localhost/vcops-custom.xml

  4. Open this file in a plain text editor:

    $ALIVE_BASE/tomcat-enterprise/webapps/vcops-custom/META-INF/context.xml


  5. In the first stanza of text, find the following line and replace 45 with an appropriate value:

    maxActive=45

  6. Save and close the file.
  7. Issue the following command to start the Custom UI:

    service vcopswebenterprise start

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