Knowledge Base
The VMware Knowledge Base provides support solutions, error messages and troubleshooting guides

|
Upgrading to VMware Tools 5.1 causes log spew with the message: Error in the RPC receive loop: RpcIn: Unable to send (2036350)
Symptoms
- In the Windows Application Event log, you see this error reported multiple times in quick succession (log spew):
Error in the RPC receive loop: RpcIn: Unable to send.
- On a Linux guest OS, you see log spew of:
vmusr[2116]: [warning] [vmusr] Error in the RPC receive loop: RpcIn: Unable to send.
or
[warning] [vmsvc:guestinfo] Conversion to UTF-8 failed
[warning] [vmsvc:guestinfo] Failed to get vmstats
- User instances of
vmtoolsdcrash with this error:
Access violation (0xC0000005)
- You cannot map network drives.
- You are experiencing disconnected terminal sessions.
Cause
Thus the Windows Application Event log fills up with warning messages similar to this until the total connection count is >2 per session:
[vmusr:vmusr] Error in the RPC receive loop: RpcIn: Unable to send.
Resolution
This issue is resolved in VMware ESXi 5.1 Patch 3. For more information, see VMware ESXi 5.1, Patch Release ESXi510-201310001 (2053402). To download this patch go to Download Patches.
To disable VMware Tools application event logging:
- Open the tools.conf file using a text editor. The tools.conf file is located at:
- Windows XP and Windows Server 2000/2003:
C:\Documents and Settings\All Users\Application Data\VMware\VMware Tools\
- Windows Vista, Windows 7, and Windows Server 2008:
C:\ProgramData\VMware\VMware Tools\
- Linux:
/etc/vmware-tools/tools.conf
Note: If the tools.conf file is not present, create the file manually using a plain text editor.
- Windows XP and Windows Server 2000/2003:
- Add this section to the tools.conf file:
[logging]
vmusr.level = error
vmsvc.level = error
- Save and close the file.
- Restart the VMTools service (Administrative Tools > Services).
Note: If there are users logged in to more than one session, restarting the VMTools service may not be sufficient. You may have to kill the vmtoolsd.exe process for all instances.
To disable general virtual machine logging:
- Click the virtual machine in the Inventory.
- On the Summary tab for that virtual machine, click Edit Settings.
- In the virtual machine Properties dialog box, click the Options tab.
- Under Advanced, click General and deselect Enable logging.
- Click OK to save the change.
- To make the change take effect, power off the virtual machine and power it back on again.
- If the issue continues, try uninstalling and reinstalling VMware Tools.
Note: If you do not want to power off your virtual machine to disable logging, you can also use vMotion to migrate the virtual machine after changing this setting.
Additional Information
See Also
Update History
Request a Product Feature
To request a new product feature or to provide feedback on a VMware product, please visit the Request a Product Feature page.
Actions
KB:
- Updated:
- Categories:
- Languages:
- Product Family:
- Product(s):
- Product Version(s):

