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Upgrading to VMware Tools 5.1 causes log spew with the message: Error in the RPC receive loop: RpcIn: Unable to send (2036350)

Symptoms

After upgrading a Terminal Server or Terminal Server-based Citrix XenApp virtual machine to VMware Tools 5.1, you experience these symptoms:
  • In the Windows Application Event log, you see this error reported multiple times in quick succession (log spew):

    Error in the RPC receive loop: RpcIn: Unable to send.

  • On a Linux guest OS, you see log spew of:

    vmusr[2116]: [warning] [vmusr] Error in the RPC receive loop: RpcIn: Unable to send.

  • In the vmware.log file for the virtual machine, you see this log spew:

    GuestRpc: Channel X, conflict: guest application toolbox-dnd tried to register, but it is still registered on channel Y
    GuestRpc: Channel X reinitialized.


  • User instances of vmtoolsd crash with this error:

    Access violation (0xC0000005)

  • You cannot map network drives or
  • You are unable to experience disconnected terminal sessions
Note: This issue may also occur on non-Terminal Servers, such as Windows 2008 and 2003, and Linux distributions.

Cause

This issue occurs when the VMware Tools daemon (vmtoolsd) handles more than two Terminal Sessions. When a user connects to a Windows virtual machine, each terminal session should have one vmtoolsd running; however, vmtoolsd is limited to only two sessions running simultaneously. 

Thus the Windows Application Event log fills up with warning messages similar to this until the total connection count is >2  per session:

[vmusr:vmusr] Error in the RPC receive loop: RpcIn: Unable to send.


Resolution

This issue is resolved in ESXi 5.1 Patch ESXi51-0201212402-BG. To download this patch, see VMware ESXi 5.1., Patch ESXi510-201212402-BG: Updates tools-light (2035778). Alternately, this patch has been integrated into ESXi 5.1 Update 1. You can download the latest release from the vSphere Download Center.

If this issue persists, you can disable VMware Tools logging to the Event Log and general virtual machine logging to the vmware.log file for the virtual machine.

To disable VMware Tools application event logging:
  1. Open the tools.conf file using a text editor. The tools.conf file is located at:

    • Windows XP and Windows Server 2000/2003:

      C:\Documents and Settings\AllUsers\ApplicationData\VMware\VMware Tools\

    • Windows Vista, Windows 7, and Windows Server 2008:

      C:\ProgramData\VMware\VMware Tools\

    • Linux:

      /etc/vmware-tools/tools.conf

    For more information, see the Configuration File Location section in Enabling debug logging for VMware Tools within a guest operating system (1007873).

    Note: If the tools.conf file is not present, create the file manually using a plain text editor.

  2. Add this section to the tools.conf file:

    [logging]
    vmusr.level = error


  3. Save and close the file.
  4. Restart the VMTools service (Administrative Tools > Services).

    Note: If there are users logged in to more than one session, restarting the VMTools service may not be sufficient. You may have to kill the vmtoolsd.exe process for all instances.

To disable general virtual machine logging:
  1. Click the virtual machine in the Inventory.
  2. On the Summary tab for that virtual machine, click Edit Settings.
  3. In the virtual machine Properties dialog box, click the Options tab.
  4. Under Advanced, click General and deselect Enable logging.
  5. Click OK to save the change.
  6. To make the change take effect, power off the virtual machine and power it back on again.
  7. If the issue continues, try uninstalling and reinstalling VMware Tools.

    Note: If you do not want to power off your virtual machine to disable logging, you can also use vMotion to migrate the virtual machine after changing this setting.


Additional Information

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See Also

Update History

09/28/2012 - Added that this can also be seen on non Terminal Servers 01/29/2013 - Added additional error to Symptoms 01/29/2013 - Added note to regarding killing the vmtoolsd.exe process.

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