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Update Option Values tasks visible in vCenter Server after enabling Content Based Read Cache (CBRC) (2035729)

Symptoms

After enabling Content Based Read Cache (CBRC) in View 5.1, you see tasks in vCenter Server with the name Update option values with a status of A general system error occurred.

Cause

This issue occurs due to a lack of permissions on the vCenter Server account. You see these tasks because CBRC is not enabled on the ESXi hosts. 

Resolution

To resolve this issue, manually set the option value to true on the ESXi hosts:

  1. Make sure all ESXi hosts involved have access to all datastores on which the virtual machines reside.
  2. On the vCenter Server, select the host and click the Configuration tab. 
  3. In the Software menu, click Advanced Settings.
  4. Navigate to CBRC and select CBRC.Enable.
This option does not get enabled when the vCenter Server user does not have sufficient privileges. Verify that the user has the appropriate privileges under Host > Configuration
 
To avoid seeing these vCenter Sever tasks, disable CBRC in View:  
  1. Log into the View Administrator console.
  2. Go to View Configuration > Servers.
  3. Select the vCenter Server and click Edit.
  4. On the Host Caching tab, deselect Enable host caching for View.
  5. Click OK.

Additional Information

When you enable host caching for a vCenter Server through the View Administrator console, ESXi hosts are not configured immediately. Create a pool and enable the pool setting Use Host Caching in the Advanced Storage Settings tab.
 
During the pool creation (if it is an automated pool), you can see a vCenter Server task called Update option values. This means ESXi is configured for host caching.

Update History

11/20/2012 - Added info on how to disable CBRC in View 02/01/2011 - Added information about ensuring that datastores are accessible to ESXi hosts to the Resolution sections.

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