Knowledge Base
The VMware Knowledge Base provides support solutions, error messages and troubleshooting guides

|
Using SQL Query plugin to connect to Oracle Database using vFabric Hyperic 4.5.x fails with error: ORA-01017: invalid username/password; logon denied (2035349)
Symptoms
- Attempting to configure a SQL Query resource that executes a jdbcQuery against an Oracle database results in the following error being displayed:
ORA-01017: invalid username/password; logon denied
- The error above displays even though you have configured the resource using the correct credentials.
Purpose
This article provides information on resolving Oracle connection errors related to the JDBC driver version.
Cause
The Oracle JBC driver used by the Agent is not compatible with the version of Java that is used by the Hyperic Agent.
This can occur in versions of vFabric Hyperic that include the ojdbc14.jar Oracle JDBC driver file.
This issue can occur with:
- vFabric Hyperic Agent 4.5.3
- vFabric Hyperic Agent 4.5.3.1.
- an agent that is using the ojdbc14 jar file
Resolution
To resolve this issue:
- You must replace the Oracle JDBC driver that is used by the Agent. For more information, see What to do After Installing the HQ Server and HQ Agent on the Hyperic 4.5. Documentation dashboard.
Note: In Hyperic HQ, the plugins packaged with the HQ Agent for MSSQL, Oracle, Informix, DB2, and Sybase do not include the database vendor's JDBC plugin.
- After installing Hyperic HQ, you must download and install the vendor-provided JDBC drivers for these plugins to work. Install drivers in the following location:
AgentHome/bundles/AgentBundle/pdk/lib/jdbc
Note: The database plugins in vFabric Hyperic include the JDBC drivers.
- Go to the Oracle Technology Network and download the Oracle JDBC driver.
Note: Oracle maintains a reference that you may use to determine the appropriate JDBC driver for the versions of Oracle and Java you are using in your environment.
- Once you have installed the appropriate JBDC driver, restart the agent and verify that it is able to successfully connect to the Oracle instance.
Tags
Request a Product Feature
To request a new product feature or to provide feedback on a VMware product, please visit the Request a Product Feature page.
Actions
KB:
- Updated:
- Categories:
- Languages:
- Product Family:
- Product(s):
- Product Version(s):

