Knowledge Base

The VMware Knowledge Base provides support solutions, error messages and troubleshooting guides
 
Search the VMware Knowledge Base (KB)   View by Article ID
 

VMware ESXi 5.0 host fails with a Purple Screen Of Death when using Broadcom Corporation NetXtreme II BCM57810 10 Gigabit Ethernet cards (2034766)

Symptoms

When using Broadcom Corporation NetXtreme II BCM57810 10 Gigabit Ethernet cards you may experience these symptoms:
  • ESXi hosts fail with a purple diagnostic screen.
  • You see the error:

#DE Exception 0 in world 689994:vmast.689993 @ 0x41801136692a

2012-09-04T15:43:48.528Z cpu17:689994)0x41225d2876e0:[0x41801136692a]TSO_Split@vmkernel#nover+0x23d stack: 0x41225d287780, 0x4100380b2940
2012-09-04T15:43:48.528Z cpu17:689994)0x41225d287820:[0x418011341f6b]Vmxnet3VMKDevRxWithLock@vmkernel#nover+0x39a stack: 0x41000d980000,
2012-09-04T15:43:48.528Z cpu17:689994)0x41225d2878c0:[0x4180113444cc]Vmxnet3VMKDevRx@vmkernel#nover+0x3fb stack: 0x4100112df940, 0x113f7c
2012-09-04T15:43:48.529Z cpu17:689994)0x41225d287930:[0x41801131a00b]IOChain_Resume@vmkernel#nover+0x17a stack: 0x4100112df940, 0x41001a6
2012-09-04T15:43:48.529Z cpu17:689994)0x41225d287960:[0x41801130921d]PortOutput@vmkernel#nover+0xac stack: 0x4100112df940, 0x41225d287ac0
2012-09-04T15:43:48.529Z cpu17:689994)0x41225d2879c0:[0x41801180b36d]EtherswitchForwardLeafPortsQuick@<None>#<None>+0xdc stack: 0x4124811
2012-09-04T15:43:48.530Z cpu17:689994)0x41225d287bc0:[0x41801180cbb8]EtherswitchPortDispatch@<None>#<None>+0x138f stack: 0x1100000018, 0x
2012-09-04T15:43:48.530Z cpu17:689994)0x41225d287c20:[0x418011309750]Port_InputResume@vmkernel#nover+0x113 stack: 0x10000020000001b, 0x41
2012-09-04T15:43:48.530Z cpu17:689994)0x41225d287c60:[0x4180112fca93]Net_AcceptRxList@vmkernel#nover+0x122 stack: 0x41001125a700, 0x1, 0x
2012-09-04T15:43:48.531Z cpu17:689994)0x41225d287cc0:[0x41801137ea8e]NetPollWorldletCallback@vmkernel#nover+0x5d stack: 0x4180112429d8, 0
2012-09-04T15:43:48.531Z cpu17:689994)0x41225d287d70:[0x4180112ed741]WorldletProcessQueue@vmkernel#nover+0x398 stack: 0x70000000c, 0xa, 0
2012-09-04T15:43:48.532Z cpu17:689994)0x41225d287db0:[0x4180112edc79]WorldletBHHandler@vmkernel#nover+0x60 stack: 0xc, 0x418044400058, 0x
2012-09-04T15:43:48.532Z cpu17:689994)0x41225d287e10:[0x41801121847c]BHCallHandlers@vmkernel#nover+0xbb stack: 0xffffffffffffffff, 0x4122
2012-09-04T15:43:48.533Z cpu17:689994)0x41225d287e50:[0x41801121896b]BH_Check@vmkernel#nover+0xde stack: 0x41000d988000, 0x6e10a16568f1,
2012-09-04T15:43:48.533Z cpu17:689994)0x41225d287fa0:[0x4180112bd414]VmMemCowPShareFn@vmkernel#nover+0xc43 stack: 0x41225d287ff0, 0x41004
2012-09-04T15:43:48.533Z cpu17:689994)0x41225d287ff0:[0x41801129fdf4]VmAssistantProcessTask@vmkernel#nover+0x19f stack: 0x0, 0x0, 0x0, 0x

Note: To date this issue has only been seen on HP ProLiant DL380p Gen8 hosts.

Cause

This issue is caused by theĀ bnx2x driver.

Resolution

This is a known issue affecting VMware ESXi 5.0.

Additional Information

To be alerted when this article is updated, click Subscribe to Document in the Actions box.

See Also

Request a Product Feature

To request a new product feature or to provide feedback on a VMware product, please visit the Request a Product Feature page.

Feedback

  • 10 Ratings

Did this article help you?
This article resolved my issue.
This article did not resolve my issue.
This article helped but additional information was required to resolve my issue.
What can we do to improve this information? (4000 or fewer characters)
  • 10 Ratings
Actions
KB: