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Degraded Windows network file copy performance after full ESXi 5 VMware Tools installation (2034490)
Symptoms
- Copying files to or from a CIFS share takes considerably longer than before the install.
- The impact is especially noticeable if one side of the copy is not capable of SMB 2.0.
- Disabling the VMCI or the
vsepfltdriver resolves the performance issue (requires reboot). - Unloading the
vsepfltfilter resolves the performance issue (no reboot required).
Cause
Due to certain handling implementations in the filter driver and restrictions in the filter driver framework, file copy operations to or from a Windows network share might have noticeably impacted performance.
Resolution
- ESXi 5.0 Update 2, For more information, see VMware ESXi 5.0 Update 2 Release Notes. Download the latest version at VMware Downloads.
- ESXi 5.1 Update 1, For more information, see VMware ESXi 5.1 Update 1 Release Notes. Download the latest version at VMware Downloads.
If you cannot update and you are not using vShield Endpoint for antivirus protection, unload the filter driver and disable it.
- Click Start > Run, type
cmdand press Enter to open a command prompt. - To view the currently loaded filters, run the command:
C:\> fltmc
Filter Name Num Instances Altitude Frame
---------------------- ------------- ------------ -----
vsepflt 5 328200 0
luafv 1 135000 0
- To unload the
vsepfltdriver, run the command:C:\> fltmc unload vsepflt
- To prevent the
vsepfltdriver from loading on subsequent reboots:
Note: Before making any registry modifications, ensure that you have a current and valid backup of the registry and the virtual machine. For more information on backing up and restoring the registry, see the Microsoft article 136393.
- Click Start > Run, type
regedit, and press Enter. The Registry Editor window opens. - Navigate to:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\vsepflt
- Locate the
StartDWORD. - Right-click
Startand click Modify. - Change the value to
4and click OK. - Click File > Exit to close the Registry Editor.
Note: For more information on the Services subkeys, see the Microsoft article CurrentControlSet\Services Subkey Entries.
- Click Start > Run, type
Note: If you are using vShield Endpoint for antivirus protection, please file a support request with VMware Technical Support and note this Knowledge Base article ID (2034490) in the problem description. For more information, see Filing a Support Request in My VMware (2006985).
Note: The links in this article were correct as of December 28, 2012. If you find a link is broken, provide feedback and a VMware employee will update the link.
See Also
Request a Product Feature
To request a new product feature or to provide feedback on a VMware product, please visit the Request a Product Feature page.
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