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Troubleshooting issues with the scripted installation of vCenter Protect agents (2031987)

Symptoms

  • Cannot perform a scripted installation of the vCenter Protect agent
  • Scripted installation of a vCenter Protect agent fails

Cause

The scripted installation of the vCenter Protect agent may fail due to one of these issues:
  • Syntax script issues
  • DNS resolution issues
  • Authentication issues
  • Port issues

Resolution

To troubleshoot issues with the scripted installation of vCenter Protect agents:

  1. Ensure that your vCenter Protect console server and target agent machine satisfy the prerequisites for agent scanning, deployment, and installation. For more information, see:
  2. Ensure that there are no any special characters, such as "$%&*@#!", and spaces in the console hostname or policy name.

    If there are special characters or spaces in the hostname, use the IP address instead. If there are special characters or spaces in the policy name, alter the policy name within the Protect Console and the change the policy name within the script.

    Note: It may be possible to use names with spaces due to the quotation marks around the string value. However, this still causes issues with the scripted installation.

  3. Verify if there are DNS resolution issues by testing with both the console machine hostname and IP address. Ensure that DNS is correctly configured within your environment.
  4. If you are using a passphrase, go to the Protect console and change the passphrase and then use the new one within your script. For more information, see VMware vCenter Protect Agent Options.
  5. If you are using Windows Authentication, ensure that your credentials have administrative permission to the vCenter Protect console machine.
  6. The scripted installation requires the agent to make a Web call over port 3121 to initiate contact with the vCenter Protect console. Therefore, ensure that the firewall or proxy rules are not blocking any of the ports, thus preventing this communication.
If the preceding troubleshooting steps do not resolve the issue, try installing the agent using the GUI executable STplatformUpdater.exe. If this is successful, you may have a syntax issue within your script. For more information, see Manually Installing VMware vCenter Protect Agent

If the issue still persists:

  • Collect the STPlatform*.log and AgentInstaller.log files loated at C:\Windows\Temp\ or C:\Windows\Temp\{stringvalue}\%temp%\.
  • File a support request with VMware Support and quote this Knowledge Base article ID (2031987) in the problem description. For more information, see How to Submit a Support Request.

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