Knowledge Base

The VMware Knowledge Base provides support solutions, error messages and troubleshooting guides
 
Search the VMware Knowledge Base (KB)   View by Article ID
 

Heartbeat Server R2 service fails to start (2031657)

Symptoms

  • The Heartbeat service fails
  • The Neverfail Server R2 service will not start
  • The Neverfail Server R2 service successfully starts but terminates unexpectedly
  • In the NFClientLog.txt file (located in C:\Program Files\VMware\VMware vCenter Server Heartbeat\R2\logs), you see errors similar to:

    [2012-07-04 19:08:35,106]ERROR 10534[AWT-EventQueue-0](com.neverfail.publicidentity.IPFlip) - WMIHelper::GetWMIObject() failed to excecute query : SELECT * FROM Win32_NetworkAdapterConfiguration WHERE IPEnabled ='TRUE' Invalid class
    hr error code : -2147217392

    [2012-07-04 19:08:35,107]ERROR 10535[AWT-EventQueue-0](com.neverfail.publicidentity.IPFlip) - WMIHelper::GetNetworkAdapters() GetWMIObjects(Win32_NetworkAdapterConfiguration, IPEnabled) failed -2147217392

    [2012-07-05 09:23:55,057]ERROR347166[AWT-EventQueue-0](com.neverfail.publicidentity.IPFlip) - WMIHelper::GetWMIObject() failed to excecute query : SELECT * FROM Win32_NetworkAdapterConfiguration WHERE IPEnabled ='TRUE' Invalid class
    hr error code : -2147217392

    [2012-07-05 09:23:55,058]ERROR347167[AWT-EventQueue-0](com.neverfail.publicidentity.IPFlip) - WMIHelper::GetNetworkAdapters() GetWMIObjects(Win32_NetworkAdapterConfiguration, IPEnabled) failed -2147217392

Cause

The service fails to start if the Windows Management Instrumentation (WMI) objects are not all successfully loaded on the Windows server.

Resolution

To confirm the cause of this issue:

  • Verify that all WMI classes are loaded properly:

    • Open Windows PowerShell and run this command:

      get-wmiObject –list | Measure-Object

      Example output:

      Count    : 82

      When the WMI classes are loaded properly, the Count is higher than 900. If the Count is low, for example less than 100, all of the WMI classes have not loaded.

  • Verify that WMI is running properly:

    1. Open the Computer Management application. Click Start > Run, type compmgmt.msc, and click OK.
    2. In the left pane, click Services and Applications, then right-click WMI Control in the right pane and click Properties.
    3. If you see a message similar to Failed to initialize all required WMI classes, WMI is not running properly.


To resolve this issue, reload the WMI repository:

  1. Click Start > Run, type services.msc, and click OK. The Services window opens.

  2. Right-click the Windows Management Instrumentation service and click Stop.

    Note: If the service does not stop or you receive an error, restart the Windows Event Log service. You can then stop the WMI service.

  3. Rename the WMI Repository folder. For example, change the name to Repository-old. The Repository folder is located in:

    C:\Windows\System32\wbem

  4. Re-register the WMI DLLs:

    1. Click Start > Run, type cmd and click OK to open a command prompt.
    2. Change directory to C:\Windows\SysWOW64\wbem. For example:

      cd C:\Windows\SysWOW64\wbem

    3. Re-register the DLLs by running this command:

      for %i in (*.dll) do RegSvr32 -s %i

  5. Start the Windows Management Instrumentation service from the Services window.

  6. Start the Neverfail Server R2 service from the Services window.



Additional Information

Request a Product Feature

To request a new product feature or to provide feedback on a VMware product, please visit the Request a Product Feature page.

Feedback

  • 0 Ratings

Did this article help you?
This article resolved my issue.
This article did not resolve my issue.
This article helped but additional information was required to resolve my issue.
What can we do to improve this information? (4000 or fewer characters)
  • 0 Ratings
Actions
KB: