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Deleting linked clones in View Manager fails with the error: Failed to cleanup linked clone (2031433)

Symptoms

  • Cannot delete linked clones in View Manager
  • Deleting linked clones fail
  • In the View Admin console, you see the error:

    Failed to delete VM - Failed to cleanup linked clone /View-DC/vm/PoolName/VM-1 from view composer: Failed

  • In the vmware-viewcomposer.log file, you see errors similar to:

    2012-07-13 16:22:00,373 | WFE thread 13 | FATAL | ServiceCore.Action.RemoveFromAdDomainAction - Error: fail to execute RemoveFromAdDomainAction,guest:AMD-1, AD domain config Id:34dbcdb6-d0ba-4fbb-81d0-cead73183637.
    VMware.Sim.CommonLib.Exception.SimAdsException: Logon failure: unknown user name or bad password.
    ---> System.Security.Authentication.AuthenticationException: Logon failure: unknown user name or bad password.
    ---> System.DirectoryServices.DirectoryServicesCOMException (0x8007052E): Logon failure: unknown user name or bad password.

Cause

This issue occurs if the View Composer domain credentials have changed. As a best practice, VMware recommends you to use a service account, instead of a user account with Administrator privileges.

Resolution

To resolve the issue:
  1.  In the View Admin console, expand Inventory.
  2. Click Pools.
  3. Select the pool experiencing the issue and click Edit.
  4. Click the Guest Customization tab.
  5. Note the domain username that is used to join the linked clones to the domain.
  6. Click Cancel.
  7. Expand View Configuration.
  8. Click Servers.
  9. Select the appropriate vCenter Server.
  10. Click Edit.
  11. Under View Composer Settings, select the domain username from Step 5.
  12. Click Edit.
  13. Update the username and password fields with the correct credentials.
  14. Click OK.
  15. Click OK.

Note: If your problem still exists after trying the steps in this article, file a support request with VMware Support and note this Knowledge Base article ID (2031433) in the problem description. For more information, see How to Submit a Support Request.

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