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vCenter Service status displays cannot access the health service when using default SSL certificates (2031299)

Symptoms

  • When viewing the vCenter Server Status in the vSphere Client, a yellow banner warning is displayed: 

    vCenter Service Status: Cannot access the health service!

  • When connecting the ADSI Edit MMC to the ADAM instance, the Health OU is missing.
  • In the vws.log, you see errors similar to:

    [2012-06-28 13:50:02,131 VwsInit  ERROR com.vmware.vim.health.impl.HealthServiceImpl] Exception while starting Health Service:
    [2012-06-28 13:50:18,183 Thread-61  ERROR com.vmware.vim.cimmonitor.qs.provider.impl.QsHelperImpl] Failed to query
    [2012-06-28 15:07:33,192 http-8443-5  ERROR com.vmware.vim.health.gwt.server.GwtHealthServiceImpl] HealthService not initialized
    [2012-06-28 15:08:38,807 http-8443-5  ERROR com.vmware.vim.health.gwt.server.GwtHealthServiceImpl] HealthService not initialized


  • In the sms.log, you see errors similar to:

    2012-06-28 13:52:15,854 [Thread-17] INFO  com.vmware.vim.sms.HealthAgentImpl  - Changing health status from INIT_IN_PROGRESS to OPERATIONAL
    2012-06-28 13:52:15,854 [Thread-17] DEBUG com.vmware.vim.sms.HealthAgentImpl  - Publishing service health information

Purpose

This article provides information on:

Cause

This issue may be caused when the ADAM database installed on the vCenter Server has a corrupted or missing OU=Health container, prompting this error in the vCenter Server Status pane.

Resolution

To resolve this issue, verify that the Health OU is missing from the ADAM database.

To verify that the Health OU is missing:
  1. Log into the vCenter Server as an Administrator.
  2. Click Start > Administrative Tools > ADSI Edit.
  3. Click Action, then clickConnect to.
  4. Under Connection Point, click Select or Type a Distinguished Name or Naming Context and type:

    dc=virtualcenter, dc=vmware, dc=int

  5. Under Computer, select Select or type a domain or server and type:

    localhost:389

  6. Click OK.
  7. Expand the Default Naming Context section.
  8. Expand dc=virtualcenter, dc=vmware, dc=int and verify if OU=Health is missing from the ADAM database.

If the OU=Health is missing from the database, you must reinstall vCenter Server.

To reinstall vCenter Server:
  1. Stop the vCenter Server Service. For more information, see Stopping, starting, or restarting vCenter services (1003895).
  2. Back up the vCenter Server database. For more information, see Backing up the vCenter Server database running on Microsoft SQL or SQL Express server (2012138).
  3. Uninstall vCenter Server. For more information, see Best practices for uninstalling vCenter Server (1030559).
  4. Reinstall vCenter Server and select the existing 64-bit DSN and select the Do not overwrite, leave my existing database in place option.
  5. Start the vCenter Server Service. For more information, see Stopping, starting, or restarting vCenter services (1003895).

Notes:
  • Hosts and virtual machines can remain powered on during this process, so there should be minimal to no impact to production.
  • The existing database can remain attached to the existing SQL Server instance.
  • The existing database preserves all inventory hierarchies, custom roles, and permissions propagation data.

Impact/Risks

This error does not impact production. However, vSphere Client users will not be able to view the overall health status of the vCenter Server system using the vCenter Server Status.

See Also

Request a Product Feature

To request a new product feature or to provide feedback on a VMware product, please visit the Request a Product Feature page.

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