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Extension fields are multiplying data every time the call or request is loaded in VMware Service Manager 9.x (2031109)

Symptoms

  • Screen is cloned from previous version.
  • Data multiplies each time the call is opened.
  • You are unable to open a call when extension field data has grown too large due to the data that multiplies each time the call is opened.
  • Screen has extensions that are multiplying their data when a call is actioned. 
  • When a call is saved, the contents of the field are appended to the field. 
  • Extension fields multiply data each time a call or request is loaded.

Purpose

This article describes a specific set of issues. If you experience any of the above symptoms, consult the sections below.

Cause

This is a known defect. Our developers have not yet determined which rolling patch this defect will be fixed in.

Resolution

This is a known issue affecting VMware Service Manager 9.x. Currently, there is not resolution.
 
To workaround this issue:
  1. Check the screens source code for the extension field saved in the deadzone.
  2. In Designer load the screen where the issue occurs.
  3. Click Save as to save the screen out of Service Manager. 
  4. Locate the saved file.
  5. Open the file using a plain text editor. 
  6. Identify the Extension field that is multiplying and search the field within the deadzone. If found, remove the duplications.
  7. Save the file.
  8. Import the file back into Designer and test. 
 
Note: If the problem began occurring after the workflow was cloned and the Extension field is not found in the deadzone, create a new clone to remove the duplications. 

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