Knowledge Base

The VMware Knowledge Base provides support solutions, error messages and troubleshooting guides
 
Search the VMware Knowledge Base (KB)   View by Article ID
 

ESX host booting from SAN or local storage stops with error at vsd-mount (2030355)

Symptoms

  • An ESX 4.x host fails at boot up and enters Troubleshooting mode.
  • In the console, you see:

    • The last successful command is cos-snapshot.
    • A message indicating that vsd-mount has failed.

  • You see the message:

    You have entered the recovery shell. The situation you are in may be recoverable.
    If you are able to fix this situation the boot process will continue normally after you exit this terminal
    /bin/sh: can't access tty: job control turned off.

Cause

This issue can occur if the ESX host is unable to correctly load the driver necessary to access the files used for the Service Console (COS) because the parameters for loading the device driver are incorrect or the driver has been disabled.

You can find additional information regarding the incorrect parameter in the /proc/vmware/log file.

Resolution

To determine if this article applies to your situation:

  1. Check if the driver necessary to access your storage is loaded correctly by running this command:

    esxcfg-module -l | grep scsi_module

    Where scsi_module is the driver necessary to access the device where the service console is located.

    If the service console is located on a storage array, the driver could be:

    • qla2xxx  (Qlogic FC HBAs)
    • qla4xxx  (Qlogic FC HBAs)
    • lpfc820  (Emulex FC HBAs)
    • bnx2i    (Broadcom HW iSCSI)

    If the service console is located on local storage, this driver could be:

    • mptspi
    • mptsas
    • mpt2sas
    • aacraid
    • 3w-9xxx
    • megaraid_sas
    • megaraid2
    • cciss
    • hpsa

  2. If the output from the esxcfg-module command is similar to these examples, this article applies to your situation:

    / # esxcfg-module -l| grep lpfc820
    lpfc820                       Not loaded


    /# esxcfg-module -l | grep mptspi
    mptspi                       Not loaded

To resolve this issue:

  1. Manually load the module by running the command:

    vmkload_mod scsi_module

    If the driver is loaded correctly, you see the message:

    Module scsi_module loaded successfully

  2. Type exit (do not reboot) to continue with the boot process.

  3. As soon you have full access to the service console, correct the parameters which prevented the module from loading by running the command:

    esxcfg-module -s options scsi_module

    To get the list of parameters the module accepts, run the command:

    esxcfg-module -i scsi_module

Additional Information

See Also

Request a Product Feature

To request a new product feature or to provide feedback on a VMware product, please visit the Request a Product Feature page.

Feedback

  • 0 Ratings

Did this article help you?
This article resolved my issue.
This article did not resolve my issue.
This article helped but additional information was required to resolve my issue.
What can we do to improve this information? (4000 or fewer characters)
  • 0 Ratings
Actions
KB: