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No files are installed for MCESCAN dring Linux agent installation (2021942)

Symptoms

  • Patch assessment does not function correctly.

  • You see the message:

    Unsupported OS

  • In the /opt/CMAgent/ThirdParty/1.0/PatchAssessment/patchagent/mcescan directory, no directories exist, or any existing directories (bin, etc, lib, share, and var) are empty.

  • In the install.log, you see the messages:

    rm: cannot remove `/opt/CMAgent/ThirdParty/1.0/PatchAssessment/patchagent/mcescan/bin/agentconfig': No such file or directory
    touch: cannot touch `/opt/CMAgent/ThirdParty/1.0/PatchAssessment/patchagent/mcescan/bin/agentconfig': No such file or directory
    chmod: cannot access `/opt/CMAgent/ThirdParty/1.0/PatchAssessment/patchagent/mcescan/bin/agentconfig': No such file or directory
    cp: cannot create regular file `/opt/CMAgent/ThirdParty/1.0/PatchAssessment/patchagent/mcescan/etc/.': No such file or directory
    /opt/CMAgent/ThirdParty/1.0/PatchAssessment/share/lumension/rpm/rpmrc
    sed: can't read /opt/CMAgent/ThirdParty/1.0/PatchAssessment/share/lumension/rpm/rpmrc: No such file or directory
    rm: cannot remove `/opt/CMAgent/ThirdParty/1.0/PatchAssessment/share/lumension/rpm/rpmrc': No such file or directory
    mv: cannot stat `/opt/CMAgent/ThirdParty/1.0/PatchAssessment/patchagent/mcescan/etc/yum.conf': No such file or directory


Cause

Starting in vCenter Configuration Manager (vCM) 5.4.1, the Linux agent installs a third-party component, MCESCAN from Lumension, to assess the OS and application patches installed on the system.

The vCM agent installation calls the underlying MCESCAN installation scripts, and performs some processing to allow the MCESCAN files to be relocated under the vCM agent directory structure.

The MCESCAN installation scripts can fail silently as they perform no return code checking on commands invoked from the scripts, and all stderr output is redirected to /dev/null.

The Unsupported OS message indicates that the MCESCAN installation script could not map the Linux distribution to one of the supported distributions. This problem could occur because the distribution is not supported. See the documentation for a list of supported platforms. This problem can also occur because the installation script uses the rpm command to determine the distribution and version. If the rpm command cannot be found in the path, it is treated as if the command returned no results.

Resolution

To resolve this issue:
  • Ensure that the rpm, gzip, bzip2, and tar commands exist on the target agent system.
  • Ensure that these commands can be found on the path at the time of installation.

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