Knowledge Base

The VMware Knowledge Base provides support solutions, error messages and troubleshooting guides
 
Search the VMware Knowledge Base (KB)   View by Article ID
 

The Display option in the virtual machine settings in VMware Workstation is missing (2021698)

Symptoms

  • While running a virtual machine migrated from an older version of VMware Workstation, the Display option in is not available in VM > Settings > Hardware
  • You are unable to accelerate 3D in the virtual machine

Cause

VMware workstation 5.x and later versions support the 3D acceleration feature. However, virtual machines with hardware compatibility prior to Workstation 5, do not have the display settings available.
 
Note: With hardware 3D acceleration, three-dimensional rendering on the virtual machine uses the graphics processor on your video card, instead of using valuable CPU resources drawing 3D images. To enable the function, select Accelerate 3D graphics from VM > Settings > Hardware > Display.

Resolution

To resolve this issue:

  1. Shut down the virtual machine.
  2. Upgrade the virtual hardware.

    1. Right-click the virtual machine and click Manage.
    2. Click Change Hardware Compatibility. The Change Hardware Compatibility Wizard appears.
    3. Click Next.
    4. Select Workstation 8 in the Hardware Compatibility dropdown.
    5. Click Next.
    6. When prompted, create a clone or alter the virtual machine.
    7. Click Next.
    8. Click Finish.
    9. Click Close.

  3. Edit the virtual machine settings.
  4. Select the Display option.
  5. Select the Accelerate 3D graphics option.
  6. Click OK.

Impact/Risks

When the virtual machine is upgraded to the new hardware version, some of the old features may not be available.

See Also

Request a Product Feature

To request a new product feature or to provide feedback on a VMware product, please visit the Request a Product Feature page.

Feedback

  • 1 Ratings

Did this article help you?
This article resolved my issue.
This article did not resolve my issue.
This article helped but additional information was required to resolve my issue.
What can we do to improve this information? (4000 or fewer characters)
  • 1 Ratings
Actions
KB: