Knowledge Base

The VMware Knowledge Base provides support solutions, error messages and troubleshooting guides
 
Search the VMware Knowledge Base (KB)   View by Article ID
 

vCloud Director 1.5.1 performs slowly when used with an HTTP Load Balancer, or a reverse proxy and specific versions of Java Runtime Error (JRE) (2021456)

Symptoms

  • After upgrading vCloud Director to 1.5.1, you observe performance degradation when accessing the web interface when using a reverse HTTP proxy or firewall to access the vCloud Director Cells.
  • Direct connection to the vCloud Director Cell works as expected.
  • If the proxy engine on the firewall or Load Balancer is turned off, the connection speed returns to normal behavior.

Purpose

This article describes a specific issue which can occur in specific configurations in combination with vCloud Director 1.5.1 and firewalls or Load Balancers.

Cause

vCloud Director is an application that uses the Java Runtime Environment (JRE). Java is a product provided and maintained by Oracle. VMware cannot fix or address any issues arising directly from the JRE. However, vCloud Director 1.5.1 includes the JRE Version 1.6u30. This includes several bug fixes for Java and is supported by VMware.

For a complete list of changes in this JRE Version, see http://www.oracle.com/technetwork/java/javase/6u30-relnotes-1394870.html.

One of these updates contains the fix for CVE 2011-3389.

For more information on this fix in Java, see 
http://www.oracle.com/technetwork/topics/security/javacpuoct2011verbose-443539.html.

As part of the fix the behavior of, Java and vCloud Director (with regard to SSL 3 and TLS 1.0 protocols) has changed. This may cause issues with compatibility in certain SSL/TLS implementations.
 
Note: This issue is not exclusive to vCloud Director; it also occurs in other applications that rely on Java SSL/TSL. 

Resolution

This is a known issue affecting VMware vCloud Director 1.5.x. If you are experiencing this issue, confirm with your Load Balancer or Firewall vendor whether the relevant product can correctly handle changes in Java. 

If you have already upgraded your software, open a Support Request with VMware Support and with your Load Balancer or Firewall vendor. Quote this article ID and CVE 2011-3389.

For more information on opening a Support Request, see Filing a Support Request in My VMware (2006985).

Additional Information

The preceding links were correct as of August 9, 2012. If you find the link is broken, please provide feedback and a VMware employee will update the link.

See Also

Request a Product Feature

To request a new product feature or to provide feedback on a VMware product, please visit the Request a Product Feature page.

Feedback

  • 2 Ratings

Did this article help you?
This article resolved my issue.
This article did not resolve my issue.
This article helped but additional information was required to resolve my issue.
What can we do to improve this information? (4000 or fewer characters)
  • 2 Ratings
Actions
KB: