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Searches and autocomplete tasks take a long time in Zimbra multi-server installations (2021200)

Symptoms

  • Searches and autocomplete tasks take a long time in Zimbra multi-server installations
  • The length of the delay seems to be random

Cause

When performing a multi-server installation with two or more mailboxes, by default the server-level setting of zimbraConvertdURL inherits from the value set at the global config level, which is in turn usually set as on the first store node installed.

Assuming that the ZCS administrator did not update the value for each server to point to a different convertd service (usually the same store node itself to avoid network traffic) after installation or a store addition, every store will use the same service on the first node, thus creating a bottleneck for convertd requests.

Since convertd is invoked by default on any search or autocompletion, both searches and autocompletion tasks take an excessive amount of time.

Resolution

To resolve this situation, set the zimbraConvertdURL attribute at the server level on each server to point to the zmhostname at the same location:

Note: This procedure assumes that the convertd service has been installed and enabled at installation time.

  1. Connect to each store node via SSH.
  2. Run these commands to set zimbraConvertdURL attribute:

    # su - zimbra

    $ zmprov ms `zmhostname` zimbraConvertdURL http://`zmhostname`:7047/convert


  3. To apply the changes, restart the mailboxd service by running the command:

    $ zmmailboxdctl restart

Additional Information

If the convertd service is not present on the local store node you want to tune, then you must install and enable the service. This can be done by re-running the same installer you used for the last installation/upgrade of the node, but ensure that you keep every setting suggested, with the only exception of adding the convertd service.

Note: This process requires down time, so plan accordingly.

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