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Searches and autocomplete tasks take a long time in Zimbra multi-server installations (2021200)
Symptoms
- Searches and autocomplete tasks take a long time in Zimbra multi-server installations
- The length of the delay seems to be random
Cause
Assuming that the ZCS administrator did not update the value for each server to point to a different convertd service (usually the same store node itself to avoid network traffic) after installation or a store addition, every store will use the same service on the first node, thus creating a bottleneck for convertd requests.
Since convertd is invoked by default on any search or autocompletion, both searches and autocompletion tasks take an excessive amount of time.
Resolution
zimbraConvertdURL attribute at the server level on each server to point to the zmhostname at the same location:Note: This procedure assumes that the
convertd service has been installed and enabled at installation time.- Connect to each store node via SSH.
- Run these commands to set
zimbraConvertdURLattribute:# su - zimbra
$ zmprov ms `zmhostname` zimbraConvertdURL http://`zmhostname`:7047/convert - To apply the changes, restart the
mailboxdservice by running the command:$ zmmailboxdctl restart
Additional Information
Note: This process requires down time, so plan accordingly.
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