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Removing an ESXi 5.0 host from vCenter Server inventory fails with the error: Invalid Fault (2020565)

Symptoms

  • Removing an ESXi 5.0 host from the inventory of the vCenter Server fails
  • You see the following error:

    General system error: Invalid Fault

  • The vpxd.log contains errors similar to:

    [13260 error 'Default' opID=DFF7C9FB-00001BD2] (Log recursion level 2) vmodl.fault.SystemError
    [13260 error 'Default' opID=DFF7C9FB-00001BD2] Section for VMware VirtualCenter, pid=12676, version=5.0.0, build=build-455964, option=Release
    [13260 info 'Default' opID=DFF7C9FB-00001BD2] [VpxLRO] -- ERROR task-3407 -- host-14 -- vim.ManagedEntity.destroy: vmodl.fault.SystemError:
    --> Result:
    --> (vmodl.fault.SystemError) {
    --> dynamicType = <unset>,
    --> faultCause = (vmodl.MethodFault) null,
    --> reason = "Invalid fault",
    --> msg = "vim.fault.AdminNotDisabled"


    Note: For more information on the location of vCenter Server logs, see Location of vCenter Server log files (1021804).

Cause

This issue occurs if Lockdown mode is out of sync on the vCenter Server and the ESXi host.

Resolution

To resolve this issue: 
  1. On the vCenter Server select the ESXi host, navigate to Configuration > Security Profile and check if Lockdown Mode is set to Enabled. If not, enable it by clicking Edit and selecting Enable Lockdown Mode.

  2. Check on the ESXi 5.0 host DCUI to see if lockdown mode is disabled. If it is, enable lockdown mode on the DCUI. For more information, see Enabling or disabling Lockdown mode on an ESXi host (1008077).

  3. Disable lockdown mode in vCenter Server on the ESXi host configuration tab. Disabling lockdown mode via vCenter Server properly disables lockdown mode on the ESXi host.

See Also

Request a Product Feature

To request a new product feature or to provide feedback on a VMware product, please visit the Request a Product Feature page.

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