Knowledge Base

The VMware Knowledge Base provides support solutions, error messages and troubleshooting guides
 
Search the VMware Knowledge Base (KB)   View by Article ID
 

Uploading a file as an attachment in Socialcast fails with the error: Your upload could not be completed at this time. Please try again later. (2019125)

Symptoms

  • Cannot upload a file as an attachment in Socialcast
  • Uploading a file as an attachment in Socialcast fails
  • After selecting the file, you see the error:

    Your upload could not be completed at this time. Please try again later.

Cause

This issue occurs when a Flash-based uploader attempts to upload a file to the Socialcast Web server using an untrusted SSL certificate. This can be caused by an untrusted SSL chain or by accessing the community via a hostname that is different from the hostname indicated in the SSL certificate.

Resolution

Certificate Trust

To ensure a correct chain of trust for connecting clients, use a commercially signed SSL certificate with your Socialcast community. If you are using an internal or private Certificate Authority, such as Active Directory Certificate Services, ensure that all clients contain the CA certificate in their Trusted Root stores.

For Windows Server 2008 and later, see the Microsoft Technet article Manage Trusted Root Certificates.
For Windows Server 2003, see the Microsoft Technet article Add a trusted root certification authority to a Group Policy object.
 
Note: The preceding links were correct as of April 26, 2012. If you find a link is broken, provide feedback and a VMware employee will update the link.
 
Steps to enable trust on Linux platforms vary and depends on the application. You may need to establish the trust separately for both the browser and Flash (which uses OpenSSL's CA list).

Access URL

When accessing the Socialcast community, the URL used should be the Fully-Qualified Domain Name of the system and should match the server name indicated in the SSL certificate. If there is a mismatch, the browser indicates that there is a problem with the SSL certificate, which the user can ignore. However, file uploads will continue to fail in this situation.

Request a Product Feature

To request a new product feature or to provide feedback on a VMware product, please visit the Request a Product Feature page.

Feedback

  • 0 Ratings

Did this article help you?
This article resolved my issue.
This article did not resolve my issue.
This article helped but additional information was required to resolve my issue.
What can we do to improve this information? (4000 or fewer characters)
  • 0 Ratings
Actions
KB: