Knowledge Base

The VMware Knowledge Base provides support solutions, error messages and troubleshooting guides
 
Search the VMware Knowledge Base (KB)   View by Article ID
 

Accessing a Boot Camp partition from a PGP encrypted drive in Fusion, boots to a bootguard screen (2017438)

Cause

This occurs if you have encrypted your entire Mac hard disk. That is, both the Mac HD partition and the Boot Camp partition are encrypted using Symantec's PGP Whole Disk Encryption software.

In the case of Boot Camp partition, the PGP boot loader has replaced the Windows boot loader in the Master Boot Record (MBR). When launching the Boot Camp partition via Fusion, Fusion accesses the partition data through Mac OS X, which already has access to the decrypted data. Since it has the PGP boot loader, it assumes the disk is still encrypted, and fails when it tries to decrypt it again.

For more information about launching a Boot Camp partition, see  Launching your Boot Camp partition in VMware Fusion (1014618).

Resolution

To work around the issue:
  1. Start the Boot Camp partition in Fusion, to boot to the Windows installation disc by following the steps listed under Windows XP 64-bit in the article, Performing a Windows repair on a Windows XP virtual machine in Fusion (1013846).

    Note:
    The same steps are applicable to Windows 7 (both 32-bit and 64-bit).

  2. At the Welcome screen, select the Language and Country and click Next.
  3. Click on Repair your Computer.
  4. Choose Command Prompt.
  5. Type bootrec /fixmbr and press Return.
Your Boot Camp virtual machine uses the default Windows boot loader to access the already decrypted data, while the native Boot Camp partition uses the PGP Master Boot Record (MBR) code (which is still on the physical disk) to go to the PGP prompt for the password, and decrypt the disk.

See Also

Request a Product Feature

To request a new product feature or to provide feedback on a VMware product, please visit the Request a Product Feature page.

Feedback

  • 1 Ratings

Did this article help you?
This article resolved my issue.
This article did not resolve my issue.
This article helped but additional information was required to resolve my issue.
What can we do to improve this information? (4000 or fewer characters)
  • 1 Ratings
Actions
KB: