Knowledge Base

The VMware Knowledge Base provides support solutions, error messages and troubleshooting guides
 
Search the VMware Knowledge Base (KB)   View by Article ID
 

Performance applications that use Hardware Performance Monitoring Counters do not display information correctly (2015931)

Symptoms

When using applications that rely on Hardware Performance Monitoring Counters, such as the Linux application perf:

  • The performance counter data does not display correctly
  • The performance counter data is wrong
  • The performance counter data is entirely absent from the command output

Cause

The Hardware Performance Monitoring Counters (HW PMCs) are not interpreted in VMware's virtualization products. This can cause any application that calls on the HW PMCs to display incorrect data or fail to display the counter metrics at all.

Resolution

The virtualized HW PMC features are not currently available in ESX/ESXi, VMware Workstation, and VMware Fusion.

To work around this issue, use a performance-monitoring utility that does not require the use of Hardware Performance Monitoring Counters. Be sure to read the technical documentation with your performance-monitoring applications to determine if HW PMCs are a requirement for proper operations.

Impact/Risks

HW PMCs may provide a layer of performance data not visible by conventional performance monitoring utlities. However, the risks of inaccurate data being provided by utilities using HW PMCs where they are not available may result in inaccurate data reporting.  As such, any application that uses HW PMCs should be avoided until such a time as this feature is enabled and supported on your chosen VMware virtualization product.

Additional Information

To be alerted when this article is updated, click Subscribe to Document in the Actions box.

Request a Product Feature

To request a new product feature or to provide feedback on a VMware product, please visit the Request a Product Feature page.

Feedback

  • 5 Ratings

Did this article help you?
This article resolved my issue.
This article did not resolve my issue.
This article helped but additional information was required to resolve my issue.
What can we do to improve this information? (4000 or fewer characters)
  • 5 Ratings
Actions
KB: