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Cannot manage View Pools after upgrading to vCenter Server 5.0 (2014256)

Symptoms

  • Managing View pools fails
  • You cannot recompose, refresh, or provision View pools from the View Admin console.
  • This issue occurs after upgrading vCenter Server to vSphere 5.0.

Cause

The vCenter vSphere 5.0 upgrade can rename the datastores from, for example, DATASTORE_NAME to DATASTORE_NAME(1).

If this occurs, the View pools do not have any datastores associated with them as the information in the ADAM database on the Connection Server no longer matches the information in vCenter Server.

Resolution

To resolve this issue:

  1. Disable all the pools in the View Admin console.
    1. Click Pools (under Inventory), then select each pool.
    2. Click the Status dropdown, and select Disable Pool.

  2. In vCenter Server, change the modified datastore names back to the original names. For example, change DATASTORE_NAME(1) to DATASTORE_NAME.

  3. Enable all of the pools in the View Admin console.
    1. Click Pools (under Inventory), then select each pool.
    2. Click the Status dropdown and select Enable Pool.

Additional Information

If you have mistakenly edited some of the pools in the View Admin console and changed the original datastore names to the new datastore names in vCenter Server:
  1. Disable provisioning for any pool you updated with the new datastore names.
    1. Click Pools (under Inventory), then select each modified pool.
    2. Click the Status dropdown menu and select Disable Provisioning.

  2. Navigate to Inventory > Desktops and delete any extra desktops created since the datastore name change.
  3. Disable the pool in the View Admin console:
    1. Click Pools (under Inventory), then select the pool.
    2. Click the Status dropdown and select Disable Pool.

  4. After performing steps 1-3 for every affected pool, rename the datastores in vCenter Server back to their original names.
  5. Edit each affected pool and under vCenter Settings change the datastores to the ones originally selected.
  6. Enable each effected pool in the View Admin console:
    1. Click Pools (under Inventory), then select each pool.
    2. Click the Status dropdown and select Enable Pool.

  7. Enable provisioning on each affected pool in the View Admin console:
    1. Click Pools (under Inventory), then select each pool.
    2. Click the Status dropdown and select Enable Provisioning.

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