Knowledge Base

The VMware Knowledge Base provides support solutions, error messages and troubleshooting guides
 
Search the VMware Knowledge Base (KB)   View by Article ID
 

Registering the agent with the console in vCenter Protect Essentials fails with the error: The host name in the certificate is invalid or does not match (2012654)

Symptoms

  • Cannot register the agent with the console in vCenter Protect Essentials
  • Registering the agent with the console in vCenter Protect Essentials fails
  • Installing the agent manually fails with the error:

    Unable to obtain policy

  • In the STAgentUpdater.log file, you see entries similar to:

    2011-11-14T16:33:16.8048766Z 09bc I CheckIn.cpp:235 Checking in using: https://server.vmware.example:3121/

    2011-11-14T16:33:16.9751214Z 09bc W CheckIn.cpp:258 Failed to retrieve token. Error: class STServiceModel::Wws::CWebServiceException at TrustChannel.cpp:49: (null)

    Error detail:

    There was an error communicating with the endpoint at '
    https://server.vmware.example:3121/ST/Console/STS/ConsoleSTS '.
    There was an error sending the HTTP request.
    The certificate's CN name does not match the passed value.
    The host name in the certificate is invalid or does not match

Cause

This issue occurs because there is a change in the way agents communicate with the console in vCenter Protect Essentials 8.0, which was implemented to allow the console alias feature. You may experience this issue if you have upgraded and are using agents over the Internet or some sort of routing to get to the console machine from the agents. In this case, when you install the agent manually, you enter in the uri to connect to the console. If you have an alias set on the network to route this communication to the console machine, the certificate cn nameĀ usesĀ the actual console name, whereas the agent tries to use the name in the uri.

Resolution

To resolve this issue:
  1. Navigate to Tools > Console alias editor in vCenter Protect Essentials.
  2. Add server.vmware.example as an alias.

Request a Product Feature

To request a new product feature or to provide feedback on a VMware product, please visit the Request a Product Feature page.

Feedback

  • 0 Ratings

Did this article help you?
This article resolved my issue.
This article did not resolve my issue.
This article helped but additional information was required to resolve my issue.
What can we do to improve this information? (4000 or fewer characters)
  • 0 Ratings
Actions
KB: