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Scanning Active Directory in VMware Service Manager 9.x fails with error: Unable to retrieve group data (2010794)
Symptoms
- You cannot scan the Active Directory in VMware Service Manager 9.x.
- The Active Directory scan in Service Manager 9.x fails with error:
Unable to retrieve group data
Cause
This issue occurs when the Organizational Unit does not have a unique ID in the ER_TYPE_GROUP table.
Resolution
To resolve this issue, you must remove and re-add the Organizational Unit within the resource settings. This eliminates any dependencies to that Organizational Unit, allowing you to add a unique instance of that object.
To remove and re- the Organizational Unit:
- Log in to VMware Service Manager 9.x.
- Click Admin > Integration > Resources and navigate to the resource specified for the failed scan.
- Navigate to the source type (such as Computer or User) to access the resource type user screen.
- Select the Organizational Unit and remove it.
- Click Save.
- Navigate to the resource type user screen and re-add the Organizational Unit.
The Organizational Unit should now be unique and the scan should succeed.
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