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View Connection Server reports the error: [ws_TomcatService] STDOUT: java.lang.OutOfMemoryError: Java heap space (2009877)

Symptoms

  • You are unable to connect to View desktops.
  • You are unable to provision desktops.
  • Desktop status is incorrect in the View Manager.
  • Desktop status shows (Missing) in View Manager, though the desktop is running in vCenter Server.
  • In the View Connection server debug logs, you see the error:

    [ws_TomcatService] STDOUT: java.lang.OutOfMemoryError: Java heap space

    Note: For more information on log locations, see Location of VMware View log files (1027744).

Cause

This issue occurs if the Java heap size in the View Connection server is set to a value insufficient to administer a production environment.

Insufficient Java heap memory can lead to a number of issues in the View environment.

Resolution

To resolve this issue, increase the memory of the View Connection server.

Windows Server 2003 32-bit allows you to adjust the Java heap memory by editing the registry after upgrading the memory.

To resolve this issue in Windows Server 2003 32-bit:

Note: This procedure modifies the Windows registry. Before making any registry modifications, ensure that you have a current and valid backup of the registry and the virtual machine. For more information on backing up and restoring the registry, see the Microsoft Knowledge Base article 136393.

The preceding link was correct as of November 4, 2013. If you find the link is broken, provide feedback and a VMware employee will update the link.
  1. Power down the View Connection server.
  2. Increase the memory of the server to the required 6 GB.
  3. Power on the View Connection server.
  4. Ensure that PAE (Physical Addressing Extensions) is enabled and Windows is able to see the full 6 GB of memory.

    For more information on enabling PAE, see the Microsoft Knowledge Base article 283037.

    Note: The preceding link was correct as of November 4, 2013. If you find the link is broken, provide feedback and a VMware employee will update the link.

  5. In the Registry Editor, navigate to:

    HKEY_LOCAL_MACHINE\SOFTWARE\VMware, Inc.\VMware VDM\plugins\wsnm\TomcatService\Params

  6. Change this registry setting from -Xmx512m to -Xmx1024m.
  7. Reboot the View Connection server.

Windows Server 2008 R2 requires you to reinstall the View Connection server software to adjust the Java heap.

To resolve this issue in Windows Server 2008 R2:

Note: You can also use these steps as an alternative solution for Windows Server 2003.
  1. Power down the View Connection server.
  2. Increase the memory in the View Connection server to the required 10 GB.
  3. Power on the View Connection server.
  4. Using Add/Remove programs, remove the VMware View Connection Server instance from the machine.
  5. Reinstall the VMware View Connection server using the View installer.
  6. When prompted, allow the View install to use the existing ADAM instance.

Additional Information

For more information on the View Connection server debug log, see Location of VMware View log files (1027744).

In Server 2008R2, the registry path is HKEY_LOCAL_MACHINE\SOFTWARE\VMware, Inc.\VMware VDM\plugins\wsnm\TomcatService\Params as well, but -Xmx is either 1024 or 4096, depending on if the server had below 10GB RAM at time of Connection Server software install

Warning: Do not attempt to change registry settings in Windows 2008. Applying changes may cause the operating system to crash.

For translated versions of this article, see:

See Also

Update History

08/16/2012 - Updated Step 6 to say: "Change this registry setting from -Xmx512m to -Xmx1024m" 10/04/2012 - Added to backup ADAM before making any changes and linked to backup KB 05/09/2013 - Added registry modification note. 05/21/2013 - Attached to PR 907642 05/21/2013 - Added latest release to product section.

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