Knowledge Base

The VMware Knowledge Base provides support solutions, error messages and troubleshooting guides
Search the VMware Knowledge Base (KB)   View by Article ID

Upgrading to ESXi 5.x reports the warning: Host contains third-party VIB(s) (2009014)


When upgrading to ESXi 5.x from an earlier version, you see a warning message similar to:
Custom VIBs Warning

Your system encountered following warnings during prechecks.

3RD_PARTY_SOFTWARE WARNING: Host contains third-party VIB(s) that have no substitute on the ISO.


This issue occurs if your system has custom VIBs that are not available in the ISO.

This warning is reported when the installation process finds VIB (VMware Installation Bundle) software and driver packages on your system that are not available and not supported with ESXi 5.x.


To resolve this issue, before proceeding with the upgrade, ensure that the particular make and model of the server is listed as supported in the VMware Compatibility Guide for ESXi 5.x. Also ensure that it includes a local disk where the ESXi 5.x would reside.

However, you can safely ignore this warning message and proceed with the upgrade.
To proceed with the upgrade:
  1. Choose Continue in the warning message screen.
  2. Select the Force Migrate option to proceed with the upgrade.

Note: You can also use ImageBuilder to create an ISO with VIBs that replace your custom VIBs or you can skip this warning with using the --forcemigrate command.

Additional Information

Request a Product Feature

To request a new product feature or to provide feedback on a VMware product, please visit the Request a Product Feature page.


  • 15 Ratings

Did this article help you?
This article resolved my issue.
This article did not resolve my issue.
This article helped but additional information was required to resolve my issue.
What can we do to improve this information? (4000 or fewer characters)
  • 15 Ratings