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Incorrect NIC failback occurs when an unused uplink is present for management network or iSCSI configuration (2008144)

Symptoms

  • Incorrect NIC failback occurs when an unused uplink is present in the team on VSS/VDS.
  • The following error can be seen in vCenter/vSphere client:

    The iSCSI initiator could not establish a network connection to the target

  • This issue occurs when there is an unused uplink using explicit failover policy.
  • vmk fails over to an unused uplink in the team after an down/up event of the unused uplink.
  • After rebooting the ESXi host (configured with vDS with the uplink NICs in standby or unused mode) the host may get disconnected from vCenter server
Note: This issue is also seen to occur with Software iSCSI configuration (vmk bindings).

Cause

The issue occurs if an uplink is added to the list of available uplinks, even when it is marked as Unused in the NIC Teaming policy.

Resolution

This issue is resolved in ESXi 5.0/vCenter Server 5.0 Update 1.
 
To download ESXi 5.0/vCenter Server 5.0 Update 1, see the VMware Download Center.  
 
To work around this issue in earlier releases, try one of these options:
  • Do not have any unused NICs present in the team.  
  • In the NIC Teaming policy, set Failback to No and then, from the ESXi/ESX DCUI (Direct Control User Interface), restart the management network using the Restart Management Network option.
  • Create vmkernel ports on separate vSwitches for accessing iSCSI storage. If you have multiple vmkernel interfaces configured to access the iSCSI storage, ensure to bind a vmkernel port only to a single uplink VMNIC. For more information, see the vSphere Documentation.
  • When using vDS, ensure that the Management Network dvPortGroup does not have uplink NIC in Standby or Unused mode. This particular dvPortgroup carries the management network and, therefore, all the uplink NICs must be in the active-active state.
  • You can use the Reconfigure vSwitch option for other vSwitches, other than the one used for Management Network.

Update History

11/17/2011 - Added additional workaround 02/24/2012 - Added note in the Symptoms sections 03/16/2012 - Added information that the issue is resolved in ESXi 5.0/vCenter Server 5.0 Update 1 and added link to the download center. 04/12/2012 - Added error message seen in vCenter/vSphere client to Symptoms. 06/20/2012 - Added additional workaround

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