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Installing the View Client fails with the error: Setup cannot continue. The Microsoft Runtime DLL installer failed to complete installation (2007225)

Symptoms

  • Installation of the View Client fails.
  • You see the error:

    Setup cannot continue. The Microsoft Runtime DLL installer failed to complete installation

  • The Windows Event viewer may contain either of these errors:

    • 1603 == ERROR_INSTALL_FAILURE
    • 1618 == ERROR_INSTALL_ALREADY_RUNNING

Cause

This issue may occur if another program has not completed installing and a system reboot is required.

Resolution

To resolve this issue:

Note: This procedure modifies the Windows registry. Before making any registry modifications, ensure that you have a current and valid backup of the registry and the virtual machine. For more information on backing up and restoring the registry, see the Microsoft article 136393.

  1. Reboot the machine to clear the pending operations. If the issue persists, proceed to the next step.
  2. Open the registry editor:

    • In Windows XP: Click Start > Run, type regedit, and click OK.
    • In Windows Vista/7: Click Start, type regedit, and click OK.

  3. Check for these registry keys:

    • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\PendingFileRenameOperations
    • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\FileRenameOperations

  4. If there is a string in either of these keys, delete the string.
  5. Attempt to install the VMware View Client again.

    Note: If this does not resolve the issue, you may also have to delete any strings in these keys:

    • HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\RunOnce\
    • HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\RunOnceEx\

  6. After deleting the strings, reboot the machine and attempt to install the View Client.
Note: If your problem still exists after trying the steps in this article, please file a support request with VMware Technical Support and note this Knowledge Base article ID (2007225) in the problem description. For more information, see Filing a Support Request in My VMware (2006985).

Additional Information

This issue may also occur if Windows Installer service is disabled. 

To enable the windows installer service: 
  1. Click Start > Run, type services.msc, and click OK. The Services windows opens. 
  2. Right-click Windows Installer, and then click Properties
  3. If the Startup type drop-down list is set to a value of Disable, select the Manual option from the Startup type drop-down list. 
  4. Click on Start button below the heading service status and click OK.
Note: Microsoft Fixit tool may be able to automatically resolve the Windows Installer problem. For more information see Fix problems that programs cannot be installed or uninstalled on support.microsoft.com.

See Also

Request a Product Feature

To request a new product feature or to provide feedback on a VMware product, please visit the Request a Product Feature page.

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