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ESX/ESXi 4.1 and 5.0 host fails with a purple diagnostic screen: #PF Exception 14 in a helper world mentioning timerq_RB_REMOVE_COLOR (2004337)

Symptoms

While using ESX/ESXi 4.1 or 5.0 host, with Trend Micro Deep Security installed, your host fails with a purple diagnostic screen displaying this message:

VMware ESX 4.1.0 [Releasebuild-XXXXXX X86_64]
#PF Exception 14 in World wwww: helperNN-N IP 0xNNNNNNNNN addr 0x30
...
0xNNNNNNNNN:[0xNNNNNNNNN]timerq_RB_REMOVE_COLOR@esx:nover+0x16e
0xNNNNNNNNN:[0xNNNNNNNNN]timerq_RB_REMOVE@esx:nover+0x112
0xNNNNNNNNN:[0xNNNNNNNNN]tb_timer_clear@esx:nover+0x5f
0xNNNNNNNNN:[0xNNNNNNNNN]dom_payload_exit@esx:nover+0x20
0xNNNNNNNNN:[0xNNNNNNNNN]tb_dom_exit@esx:nover+0x7a
0xNNNNNNNNN:[0xNNNNNNNNN]dsa_ureg_filter@esx:nover+0xfa
0xNNNNNNNNN:[0xNNNNNNNNN]dv_destroy_filt@esx:nover+0x8
0xNNNNNNNNN:[0xNNNNNNNNN]DVFilterCallFastPathDestroyFilter@com.vmware.vmkapi:v1_1_0_0+0x102
0xNNNNNNNNN:[0xNNNNNNNNN]helpFunc@vmkernel:nover+0x53e

Purpose

This article describes a specific issue. If you experience the above symptom, consult the sections below. If you are not experiencing this exact symptom, your issue is not related to this article. Search the KB for your symptoms, review the related articles Interpreting an ESX host purple diagnostic screen (1004250) and Purple diagnostic screen with vShield or third-party vSphere integrated firewall products (2004893) for similar issues, or Open a Support Request.

Cause

This host outage is caused by the Trend Micro Deep Security dvfilter module installed on the ESX/ESXi host: cross_dvfilter-dsa_410.7.5.0-5435.

Resolution

This issue has been resolved by Trend Micro Deep Security Virtual Appliance 7.5 SP3 Patch 1. For more information about downloading and installing the patch, see http://downloadcenter.trendmicro.com/index.php?regs=NABU&clk=latest&clkval=3801&lang_loc=1.

Note: The preceding link was correct as of November 03, 2011. If you find the link is broken, provide feedback and a VMware employee will update the link.

If the issue persists, contact Trend Micro support.

See Also

Update History

2012/03/08 - Added ESXi 5.0 to Products.

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