Knowledge Base

The VMware Knowledge Base provides support solutions, error messages and troubleshooting guides
 
Search the VMware Knowledge Base (KB)   View by Article ID
 

Remote console screen of virtual screen is blank (2003854)

Symptoms

  • If you select a virtual machine in the inventory and click the Console tab, the screen is blank.
  • You do not see an error.

Cause

This issue can occur if you logged into the VirtualCenter or the ESX host using VMware Infrastructure (VI) Client and do not have Console Interactions permissions.

Resolution

All users logged into the VirtualCenter or the ESX host using VI Client require Console Interaction permissions.
 
To grant Console Interaction permissions:
  1. Login to VirtualCenter or the host using VI Client.
  2. Select the host (if logged in to the host) or the datacenter (if logged in to the VirtualCenter)
  3. Click the Permission tab.
  4. Right-click in the blank space and choose Add Permissions.
  5. Under Users and Groups, click Add.
  6. Select the user experiencing the issue.
  7. Click Add.
  8. Click OK.
  9. Under Assigned Role, click on the plus sign (+) next to All Privileges.
  10. Click on the plus sign (+) next to Virtual Machine.
  11. Click on the plus sign (+) next to Interaction.
  12. Select Console Interaction.
  13. Select Propagate to Child Objects.

See Also

Request a Product Feature

To request a new product feature or to provide feedback on a VMware product, please visit the Request a Product Feature page.

Feedback

  • 34 Ratings

Did this article help you?
This article resolved my issue.
This article did not resolve my issue.
This article helped but additional information was required to resolve my issue.
What can we do to improve this information? (4000 or fewer characters)
  • 34 Ratings
Actions
KB: