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IPMI logs in ESX/ESXi 4.x and ESXi 5.0 consume excessive disk space after a BMC reset or firmware update (2000089)
Symptoms
-
The ESX/ESXi host appears to be in a Not Responding state
-
The host is unreachable in vCenter Server or when using the vSphere Client
- The
sfcb-vmware_raworsfcbdprocess is consuming more than 70MB of memory - The size of the
/var/log/ipmi/0/selfile is more than 50MB - The
/var/log/ipmi/0/selfile contains the log spew:System Boot:
- The size of the
/var/log/ipmi/0/sel.rawfile is more than 170MB - The
/var/log/ipmi/0/sel.rawfile contains the log spew:efef ef ef ef ef ef ef ef ef ef ef ef ef ef efefef ef ef ef ef ef ef ef ef ef ef ef ef ef ef
- The
/var/log/messageslog file contains entries similar to:sfcb-vmware_raw[nnnn]: IpmiIfcSelReadNew: failed call to IpmiIfcSelReadEntry cc = 0xff - vCenter Server reports the error:
vCenter does not support hosts of this type
- When adding or removing a port group from a VSS or when updating the VLAN ID of the port group, you may see the error:
Call "HostNetworkSystem.UpdatePortGroup" for object "networkSystem-####" on vCenter Server "<vCenter FQDN>" failed.
Operation failed, diagnostics report: Sysinfo error on operation returned status : Not found. Please see the VMkernel log for detailed error information
Purpose
This article describes a specific issue. If you experience all of these symptoms, consult the sections below. If you experience some, but not all, of these symptoms, your issue is not related to this article. Search for your symptoms in the Knowledge Base or Open a Support Request.
Cause
This issue can occur if the CIM and IPMI components in ESX/ESXi 4.x lose connectivity with the hardware Baseboard Management Controller. For example, the host may lose connectivity when the BMC firmware is updated or reset.
Note: For related information, see The ESX/ESXi host logs report the message: IPMI message handler: BMC returned incorrect response (2001933).
Resolution
Solution
This issue is resolved by vSphere 4.1 Update 2, released 2011-10-27. For more information, see the release notes.
Short-term workaround
To workaround this issue in the short-term:
Note: Only use this workaround until you can upgrade to vSphere 4.1 Update 2 or ESXi 5.1 or until you can apply the long-term workaround.
- Open a console to the ESX or ESXi host. For more information, see Unable to connect to an ESX host using Secure Shell (SSH) (1003807) or Using Tech Support Mode in ESXi 4.1 (1017910).
- Delete the sel and sel.raw files using the commands:
rm /var/log/ipmi/0/selrm /var/log/ipmi/0/sel.raw
- Restart the sfdbd service on the host using the command:
/etc/init.d/sfcbd-watchdog restart
Note: You do not need to reboot the host for the changes to take effect.
Long-term workaround
To workaround this issue in long-term:
- Open a console to the ESX/ESXi host.
For more information, see Unable to connect to an ESX host using Secure Shell (SSH) (1003807) or Using Tech Support Mode in ESXi 4.1 (1017910).
- Delete the sel and sel.raw files using the commands:
rm /var/log/ipmi/0/selrm /var/log/ipmi/0/sel.raw - Disable IPMI or CIM using one of the options:
Note: After you disable CIM/IPMI, the hardware monitoring information provided by CIM/IPMI is not available.
- Disable IPMI in the VMkernel boot options.
Set theVMKernel.Boot.ipmiEnabledoption to0orUnchecked. For more information, see Configuring advanced options for ESX/ESXi (1038578).
- Disable the CIM agent on the host. For more information, see How to disable the CIM agent on the ESX/ESXi host (1025757).
- Disable IPMI in the VMkernel boot options.
- Reboot the host for the changes to take effect.
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