Knowledge Base
The VMware Knowledge Base provides support solutions, error messages and troubleshooting guides

|
Connecting to the View Connection server fails with the error: A secure connection to the server '(null)' cannot be established (1038334)
Symptoms
- Cannot connect to the View Connection server that is behind a firewall
- Connecting to the View Connection server that is behind a firewall fails
- You see the error:
The View Connection Server authentication failed. A secure connection to the server '(null)' cannot be established.
- You see this error after you enter your log in credentials in the View Logon screen
- You do not experience this issue when the View Connection server is in your local network, without an intervening firewall
view-client-connection-issues
Cause
The same error may also be displayed if an invalid port is defined in the External URL.
Resolution
To resolve this issue, try one of these options:
- Disable secure tunneling on the View Connection Server behind the firewall .
To disable secure tunneling:
-
- In the View Admin portal, navigate to View Configuration > Servers.
- Click the Connection Server.
- Click the General tab.
- Under HTTP(S) Secure Tunnel, deselect Use Secure Tunnel connection to desktop.
- Open ports on the firewall to allow communication between the Client and Connection server. Port 80 and 443 are used to connect Client and Connection servers.
For a complete list of ports used in VMware View, see:
See Also
- TCP and UDP Ports required to access vCenter Server, ESXi/ESX hosts, and other network components
- Network connectivity requirements for VMware View Manager 4.5 and later
- View Connection server への接続が次のエラーで失敗する: A secure connection to the server '(null)' cannot be established
Update History
Request a Product Feature
To request a new product feature or to provide feedback on a VMware product, please visit the Request a Product Feature page.
Actions
KB:
- Updated:
- Categories:
- Languages:
- Product Family:
- Product(s):
- Product Version(s):

