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Deleting a large file on the NFS datastore succeeds, but reports the error: Error caused by file /vmfs/volumes/<datastore-uuid>/<filename> (1035332)

Symptoms

  • Deleting a file on the NFS datastore from the vSphere Client fails with the error:

    Error caused by file /vmfs/volumes/<datastore-uuid>/<filename>

  • Deleting a file on the NFS datastore from the command line fails with these errors:

    rm: cannot remove '<filename>': No such file or directory
    rm: cannot remove '<filename>': Input/output error


  • Refreshing the file list indicates that the file was successfully deleted
  • A tcpdump wire trace of the NFS traffic reveals a long delay in deleting the file, possibly with a retry that failed

    38 2011-02-11 18:19:17 client server NFS V3 REMOVE Call, DH:0x12345/filename  # First delete
    ...
    48 2011-02-11 18:19:28
    client server NFS V3 REMOVE Call, DH:0x12345/filename  # Retry delete
    ...
    50 2011-02-11 18:19:30 server client NFS V3 REMOVE Reply                      # Initial success
    51 2011-02-11 18:19:30
    server client NFS V3 REMOVE Reply Error:NFS3ERR_NOENT  # Retry failed

Cause

This issue occurs when the NFS server takes more than 10 seconds to respond to the NFS Delete command. The NFS client on the ESX/ESXi host times out the request after 10 seconds and the request is retried. The original request may eventually succeed, but the retry subsequently fails with NFS3ERR_NOENT because the file is already deleted. This error is relayed back to the client.

This error can be ignored because the file is successfully deleted. When you want to delete multiple files in a group, you may have to to delete each file individually.

Resolution

To avoid this error, you must configure the NFS server, so that it responds to the delete request within 10 seconds. Consult your storage array documentation for the procedure to accomplish this.
To workaround the issue, modify the DeleteRPCTimeout advanced parameter on the ESX/ESXi host to increase the default NFS Delete timeout value.

To modify the DeleteRPCTimeout parameter:
  1. Log in to the Local Tech Support Mode console of the ESX/ESXi host. For more information, see Unable to connect to an ESX host using Secure Shell (SSH) (1003807), Tech Support Mode for Emergency Support (1003677), or Using Tech Support Mode in ESXi 4.1 and ESXi 5.0 (1017910).
  2. Increase the timeout value of the DeleteRPCTimeout parameter using the esxcfg-advcfg command:

    # esxcfg-advcfg -s TIMEOUT /NFS/DeleteRPCTimeout

    Where TIMEOUT is is the value of the timeout in seconds (up to a maximum of 120 seconds)
    To increase the value to 30 seconds:

    # esxcfg-advcfg -s 30 /NFS/DeleteRPCTimeout

    Note: This parameter is available starting with ESX/ESXi 4.1 Update 2.

  3. Put the ESX/ESXi host into maintenance mode and reboot it to make the change active.

Additional Information

For more information on troubleshooting general NFS connectivity issues on ESX/ESXi, see Troubleshooting connectivity issues to an NFS datastore (1003967).

See Also

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