Knowledge Base

The VMware Knowledge Base provides support solutions, error messages and troubleshooting guides
 
Search the VMware Knowledge Base (KB)   View by Article ID
 

HP images of ESX and ESXi for ProLiant BL380 G8, BL460c G7, BL465c G7, BL680c G7, and BL685c G7 server blades (1035114)

Symptoms

The HP ProLiant BL380 G8, BL460c G7, BL465c G7, BL680c G7, and BL685c G7 server blades are certified with VMware and are included in the VMware Compatibility Guide.

To install ESXi with these blades, and to do a scripted installation with ESX, you must use HP images, not the images available on the VMware site, because the standard VMware image does not have the required NIC drivers.

There currently is no way to add these drivers during an ESXi or scripted ESX installation.

If you attempt to install ESXi with these blades or do a scripted installation of ESX using the incorrect images, you experience these symptoms:
  • Installation fails after you accept the EULA
  • You see the error:

    unable to load module /usr/lib/vmware/vmkmod/vmfs3: failure

  • In the /var/log/messages file, you see the error:

    Failed trying to get a valid VMKernel MAC address: Failure. Various vmkernel subsystems will provide lower quality of service

Resolution

When installing ESX 4.x on the HP ProLiant BL460c G7, BL465c G7, BL680c G7, and BL685c G7 server blades and all ProLiant Gen8 servers, you must include network drivers for the embedded network adapters. These network adapters require newer drivers and require the use of custom ISOs in certain situations.

ESX 4.x

  • Non-scripted installation

    For a non-scripted install of ESX, download the ESX 4.x ISO image from VMware Download Center and the network card drivers listed above. The VMware install process provides you with the opportunity to insert the missing network adapter drivers.

  • Scripted installation

    For a scripted (PXE or RDP based) install of ESX, the VMware install process does not have a mechanism for adding missing drivers. To perform a scripted install of ESX 4.x and its updates, you must download this custom image provided by HP.
Note: The drivers that are included in this image are the same ones that are available for download from the VMware site.

ESXi 4.x, 5.0, 5.1

HP publishes a custom image for ESXi that includes:
  • HP management components – CIM providers
  • NIC drivers that are required for HP servers that are not in the base image
The VMware install process for ESXi does not have a mechanism to include additional drivers. The ESXi installer checks if there is a valid NIC driver in the image and does not allow the install to proceed if a supported NIC driver is not found. If you are using the G7 blades, you must use the HP ESXi image. The HP image includes the drivers listed above.

To install ESXi 4.x, 5.0, or 5.1 and their respective updates, you must download a custom image provided by HP. For more information, see the Customize VMware ESXi Images for HP ProLiant Servers page on the HP site.

Additional Information

For more information, see the HP blog posts, HP images of ESX and ESXi for G7 server blades and VMware ESX4 and Updates.

VMware now provides the vibddi image customization tool. For more information, see:
To download the vibddi image customization tool, see the VIBDDI Image Customization Tool download page.

See Also

Update History

03/29/2012 - Added ESXi 5.0 and link to custom 03/29/2012 - Added links to vibddi and download 09/05/2013 - Updated HP custom image links

Request a Product Feature

To request a new product feature or to provide feedback on a VMware product, please visit the Request a Product Feature page.

Feedback

  • 27 Ratings

Did this article help you?
This article resolved my issue.
This article did not resolve my issue.
This article helped but additional information was required to resolve my issue.
What can we do to improve this information? (4000 or fewer characters)
  • 27 Ratings
Actions
KB: