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Generating the vm-support bundle from ESXi 4.x fails to gather the vmkernel core and PSOD dump (1033261)

Symptoms

  • Generating the vm-support bundle fails to collect the vmkernel core dump
  • Generating the vm-support bundle fails to collect the purple diagnostics screen (PSOD) core dump
  • Exporting system logs fails to collect the vmkernel core dump
  • Exporting system logs fails to collect the purple diagnostics screen (PSOD) core dump
  • When extracting the dump, you see this output:

    vmkdump_extract vmkernel-zdump-010611.13.21.1
    Warning: Header expects 97803366 byte zdump file, but stat says it's 40566784 bytes.
             (File on disk is 57236582 bytes smaller than header expected.)
             Your zdump may be corrupted or truncated. Continuing anyway.
    Created file "vmkernel-log.1".
    Created file "vmkernel-core.1".

Cause

This issue occurs because the partition in which the vm-support log is written to is too small to store the dump. When you generate the vm-support bundle, the process incorrectly uses a memory mount point that is too small to collect the vmkernel dump. This results in a truncated dump.

Resolution

This issue is resolved in ESXi 4.0 Update 3 and ESXi 4.1 Update 2.

On hosts not upgraded to these versions, t o investigate the dumpart log in the vm-support bundle, run this command:

cat workingdir/dumppart-copy.xxxxx.txt

Note: The location of workingdir can be found in the /tmp/working_dir.txt file in the log bundle.

You see an output similar to:

Single slot coredump
Created file /var/core/vmkernel-zdump-010811.03.08.1
Error running command. Unable to copy the dump partition: Error writing to fd 4: No space left on device

To work around this issue, manually gather the vmkernel dump from the scratch partition. For more information, see Manually regenerating core dump files in VMware ESX and ESXi (1002769).

Note: The scratch partition is a partition dedicated for temporary storage.

Additional Information

To extract the vmkernel log file from a vmkernel core dump, see Extracting the log file after an ESX or ESXi host fails with a purple screen error (1006796).

See Also

Update History

11/03/2011 - Added information that this issue is resolved in ESXi 4.0 Update 3 and ESXi 4.1 Update 2.

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