Knowledge Base

The VMware Knowledge Base provides support solutions, error messages and troubleshooting guides
 
Search the VMware Knowledge Base (KB)   View by Article ID
 

Adding vCenter Server to the VMware View Manager Admin console fails with the error: Error saving vCenter entry (1033223)

Symptoms

  • Unable to add vCenter Server to the VMware View Manager Admin console.
  • Adding vCenter Server to the VMware View Manager Admin console fails.
  • You see the error:

    Error saving vCenter entry

  • In the vCenter Server logs, you may see entries similar to:

    vim.LicenseAssignmentManager.queryAssignedLicenses -- B737F982-300F-4C6C-9239-30B6924A603A(A23CC193-493B-431D-8E81-EC13D9931D9E)
    [<YYYY-MM-DD>T<TIME>.937 00556 error 'App' opID=30783564] [LicMgr] Missing license key . Adding it back to the inventory.
    [<YYYY-MM-DD>T<TIME>.937 00556 info 'App' opID=30783564] Unable to decode license with error 19 using path dir://C:\Program Files\VMware\Infrastructure\VirtualCenter Server\licenses\site
    [<YYYY-MM-DD>T<TIME>.937 00556 error 'App' opID=30783564] [LDAP Client] Failed to add LDAP entry cn=,ou=Licenses,ou=Licensing,dc=virtualcenter,dc=vmware,dc=int: 0x15 (The syntax is invalid.)
    [<YYYY-MM-DD>T<TIME>.937 00556 error 'App' opID=30783564] [LDAP Client] Failed to get all pages of search result: : 0x57 (The search filter is bad.)
    [<YYYY-MM-DD>T<TIME>.937 00556 error 'App' opID=30783564] [LicMgr] Failed to execute ldap query to get usage
    [<YYYY-MM-DD>T<TIME>.937 00556 info 'App' opID=30783564] Unable to decode license with error 19 using path dir://C:\Program Files\VMware\Infrastructure\VirtualCenter Server\licenses\site
    [<YYYY-MM-DD>T<TIME>.937 00556 info 'App' opID=30783564] Unable to decode license with error 19 using path dir://C:\Program Files\VMware\Infrastructure\VirtualCenter Server\licenses\site
    [<YYYY-MM-DD>T<TIME>.937 00556 error 'App' opID=30783564] [LicMgr] Missing license key . Adding it back to the inventory.
    [<YYYY-MM-DD>T<TIME>.937 00556 info 'App' opID=30783564] Unable to decode license with error 19 using path dir://C:\Program Files\VMware\Infrastructure\VirtualCenter Server\licenses\site
    [<YYYY-MM-DD>T<TIME>.937 00556 error 'App' opID=30783564] [LDAP Client] Failed to add LDAP entry cn=,ou=Licenses,ou=Licensing,dc=virtualcenter,dc=vmware,dc=int: 0x15 (The syntax is invalid.)
    [<YYYY-MM-DD>T<TIME>.937 00556 error 'App' opID=30783564] [LDAP Client] Failed to get all pages of search result: : 0x57 (The search filter is bad.)
    [<YYYY-MM-DD>T<TIME>.937 00556 error 'App' opID=30783564] [LicMgr] Failed to execute ldap query to get usage
    [<YYYY-MM-DD>T<TIME>.953 00556 info 'App' opID=30783564] Unable to decode license with error 19 using path dir://C:\Program Files\VMware\Infrastructure\VirtualCenter Server\licenses\site
    [<YYYY-MM-DD>T<TIME>.953 00556 info 'App' opID=30783564] Unable to decode license with error 19 using path dir://C:\Program Files\VMware\Infrastructure\VirtualCenter Server\licenses\site

Cause

This issue occurs when:
  • User Access Control is turned on, on either vCenter Server or View Connection server.
  • vShield is or has been in use in this environment and is blocking vCenter Server from being added to the View setup.
  • vCenter Server is not licensed or has unlicensed components.
  • Other VMware products registered in vCenter Server with null or expired license.
  • The account that is used to add vCenter Server has inadequate permissions in vCenter Server.

Resolution

If User Access Control is enabled, disable it from both the vCenter Server or View Connection server.

If vShield is installed or was installed, you must remove the vShield licenses from vCenter Server.
 
 
To remove the licenses In vCenter Server:
  1. Click Licensing > Asset.
  2. Remove these vShield assets:
    • vShield-application-firewall
    • vShield-edge
    • vShield-endpoint

  3. Remove these DLFs from C:\Program Files\VMware\Infrastructure\VirtualCenter Server\licenses\site:
    • license-vshield-appfirewall
    • license-vshield-edge
    • license-vshield-endpoint

  4. Remove the signature of the existing vShield DLFs.
    1. In vCenter Server, go to Programs > ADAM and launch ADAM ADSI Edit.
    2. Open a connection to the Distinguished Name dc=virtualcenter,dc=vmware,dc=int.
    3. Under OU=Licensing, OU=Licenses (click the Licenses OU folder, but do not expand it), you see files of Class="vmw-vc-LicenseFiles". Look for the ones that have a shorter file name and have five octets separated by hyphens. In this set, remove the entries with:
      • "vmw-vc-LicenseFileName = license-vshield-appfirewall"
      • "vmw-vc-LicenseFileName = license-vshield-edge"
      • "vmw-vc-LicenseFileName =license-vshield-endpoint"

  5. Restart vCenter Server.‬
  6. Add vCenter Server to the VMware View configuration.
To check vCenter Server for valid licensing:
  1. Connect to the vCenter Server using vSphere Client.
  2. On the Home page, click Licensing.
  3. On the Licensing page, verify that vCenter Server and all components are licensed. For information on licensing, see Licensing ESX 4.x, ESXi 4.x, and vCenter Server 4.x (1010839).
For a list of privileges required for the View service account, see the View Manager Privileges Required for the vCenter Server User section in the VMware View Installation Guide.

Additional Information

Tags

view-connection-server  view-connection-server-configuration

See Also

Update History

01/24/2011 - Added information about User Access Control 05/09/2011 - Modified to include vSphere component Licenses. 10/20/2011 - Added View Manager 5.0 to Products and added additional cause 09/25/2012 - Added link to View Installation Guide 06/19/2013 - Added link to KB 2050369 in "Additional Information" section

Request a Product Feature

To request a new product feature or to provide feedback on a VMware product, please visit the Request a Product Feature page.

Feedback

  • 9 Ratings

Did this article help you?
This article resolved my issue.
This article did not resolve my issue.
This article helped but additional information was required to resolve my issue.
What can we do to improve this information? (4000 or fewer characters)
  • 9 Ratings
Actions
KB: