Knowledge Base

The VMware Knowledge Base provides support solutions, error messages and troubleshooting guides
 
Search the VMware Knowledge Base (KB)   View by Article ID
 

VMware ESX 4.0, Patch ESX400-201103401-SG: Updates VMkernel, CIM, Scripts, Apps, VMX, hostd (1032814)

Details

Release date: March 07, 2011

Patch Classification Security
Build Information See KB 1032822 .
Host Reboot Required Yes
Virtual Machine Migration or Shutdown Required Yes
PRs Fixed 636891, 600779, 534406, 597648, 654866, 554763
Affected Hardware N/A
Affected Software N/A
VIBs Included vmware-esx-apps
vmware-esx-backuptools
vmware-esx-cim
vmware-esx-esxcli
vmware-esx-iscsi
vmware-esx-microcode
vmware-esx-nmp
vmware-esx-perftools
vmware-esx-scripts
vmware-esx-srvrmgmt
vmware-esx-uwlibs
vmware-esx-vmkctl
vmware-esx-vmkernel64
vmware-esx-vmnixmod
vmware-esx-vmx
vmware-hostd-esx
kernel
Related CVE numbers
CVE-2010-3864, CVE-2010-2939, CVE-2010-3081, CVE-2010-1084, CVE-2010-2066, CVE-2010-2070,
CVE-2010-2226, CVE-2010-2240, CVE-2010-2248, CVE-2010-2521, CVE-2010-2524, CVE-2010-0008,
CVE-2010-0415, CVE-2010-0437, CVE-2009-4308, CVE-2010-0003, CVE-2010-0007, CVE-2010-0307,
CVE-2010-1086, CVE-2010-0410, CVE-2010-0730, CVE-2010-1085, CVE-2010-0291, CVE-2010-0622,
CVE-2010-1087, CVE-2010-1173, CVE-2010-1437, CVE-2010-1088, CVE-2010-1187, CVE-2010-1436,
CVE-2010-1641, CVE-2010-3609

 

Solution

Summaries and Symptoms

This patch provides the following updates:

This patch also resolves the following issues:
  • A denial-of-service vulnerability in the Service Location Protocol daemon (SLPD). Exploitation of this vulnerability might cause SLPD to consume significant CPU resources. The Common Vulnerabilities and Exposures Project (cve.mitre.org) has assigned the name CVE-2010-3609 to this issue.

  • Under certain conditions, esxcfg-firewall command fails, which might cause many esxcfg- commands to fail. The ESX console also displays an error message similar to the following:
    Unable to lock config file /etc/vmware/esx.conf. Try again later
    ERROR: Panic! Stack trace follows:
    ERROR: VMware::Panic VMware::Panic::DumpStackTrace

Deployment Considerations

None beyond the required patch bundles and reboot information listed in the table above.

Patch Download and Installation

See the VMware vCenter Update Manager Administration Guide for instructions on using Update Manager to download and install patches to automatically update ESX 4.0 hosts.

To update ESX 4.0 hosts when not using Update Manager, download the patch ZIP file from http://support.vmware.com/selfsupport/download/ and install the bulletin using esxupdate from the command line of the host. For more information, see the ESX 4 Patch Management Guide.

 

Request a Product Feature

To request a new product feature or to provide feedback on a VMware product, please visit the Request a Product Feature page.

Feedback

  • 1 Ratings

Did this article help you?
This article resolved my issue.
This article did not resolve my issue.
This article helped but additional information was required to resolve my issue.
What can we do to improve this information? (4000 or fewer characters)
  • 1 Ratings
Actions
KB: