Knowledge Base
The VMware Knowledge Base provides support solutions, error messages and troubleshooting guides

|
VMware ESX/ESXi 4.0 host with Broadcom bnx2x Async Driver Version 1.52.12.v40.3 experiences a loss of network connectivity and a purple diagnostic screen (1028091)
Symptoms
If you are using VMware ESX/ESXi 4.0 and Broadcom's ESX bnx2x async (independently-released) driver version 1.52.12.v40.3 or lower, you may experience these symptoms:
-
A loss of network connectivity from the host.
-
A purple diagnostic screen occurs on the ESX host (this may not occur in all cases)
-
The Broadcom bnx2x driver panics and dumps backtraces, with these messages that precede the dump output, in /var/log/vmkernel logs (/var/log/messages for ESXi):
Jun 29 23:12:23 vmkernel: 10:09:29:13.768 cpu8:4127059)<3>[bnx2x_stats_update:4640(vmnic1)]driver assert
Jun 29 23:12:23 vmkernel: 10:09:29:13.768 cpu8:4127059)<3>[bnx2x_panic_dump:658(vmnic1)]begin crash dump -
This issue has occurred with, but is not exclusive to, HP Proliant and Integrity Bladeservers using BCM57711E interfaces.
Cause
This is a known issue with the bnx2x driver version 1.52.12.v40.3.
Resolution
The updated bnx2x Async Driver Version 1.52.12.v40.8 resolves this issue. You can download the officially certified driver CD at http://downloads.vmware.com/d/details/esx4_broadcom_bcm57710_dt/ZHcqYnRldGRiZCVodw.
Notes:
- This driver has the same content as the interim hot patch which was released to some customers to test.
- Any systems currently using the hot-patch should apply the updated driver at the earliest opportunity as the hot-patch is no longer supported.
Please refer the "Additional Information" section for similar symptoms. It is recommended to upgrade to the latest version of Broadcom bnx2x driver - version 1.64.32.v40.1
Determining the running driver version
To determine the version of the driver ESX/ ESXi host terminal and run this command:
# vmkload_mod -s bnx2x |grep Version
For additional instructions on logging into an ESXi 3.5 or 4.0 server host terminal, see Tech Support Mode for Emergency Support (1003677).
Note: If above command does not return any results then you are not using the bnx2x driver on the ESX/ESXi host and this issue is not applicable.
Additional Information
- How to install async drivers on ESX/ESXi 4.x (1032936).
- Broadcom 57711E (bnx2x) NIC intermittently drops off the network
- VMware ESX/ESXi 4.1 host with Broadcom bnx2x (in-box driver version 1.54.1.v41.1-1vmw) experiences a loss of network connectivity and a purple diagnostic screen
- VMware ESX/ESXi 4.1 host with Broadcom bnx2x driver version 1.60.50.v41.2 experiences intermittent loss of network connectivity on HP Blades with Virtual Connect
See Also
Request a Product Feature
To request a new product feature or to provide feedback on a VMware product, please visit the Request a Product Feature page.
Actions
KB:
- Updated:
- Categories:
- Languages:
- Product Family:
- Product(s):
- Product Version(s):

