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Cannot create a quiesced snapshot because the snapshot operation exceeded the time limit for holding off I/O in the frozen virtual machine

Symptoms

  • Creating a quiesced snapshot fails.
  • While taking a snapshot, you see the error:

    Cannot create a quiesced snapshot because the snapshot operation exceeded the time limit for holding off I/O in the frozen virtual machine
     
  • You may also experience this issue when you are doing a hot clone of a virtual machine. You see the error: 
     
    An error occurred while quiescing the virtual machine. See the virtual machine's event log for details 'VssSyncStart' operation failed: IDispatch error #8449 (0x80042301)

  • The vpxa.log file contain entries similar to:

    Note: In VMware Infrastructure 3.x and vSphere 4.x, the log is located at  /var/log/vmware/vpx/vpxa. In vSphere 5.0, the log is located at /var/log.

    2010-10-10T22:53:31.077Z [45EEEB90 info 'Default' opID=D1D8F924-00002337-83] [VpxLRO] -- ERROR task-768 -- -- vpxapi.VpxaService.createSnapshot: vim.fault.ApplicationQuiesceFault:
    --> Result:
    (vim.fault.ApplicationQuiesceFault) {
       dynamicType = <unset>,
       faultCause = (vmodl.MethodFault) null,
       faultMessage = (vmodl.LocalizableMessage) [
          (vmodl.LocalizableMessage) {
             dynamicType = <unset>,
             key = "msg.snapshot.quiesce.vmerr",
             arg = (vmodl.KeyAnyValue) [
                (vmodl.KeyAnyValue) {
                   dynamicType = <unset>,
                   key = "1",
                   value = "5",
                },
                (vmodl.KeyAnyValue) {
                   dynamicType = <unset>,
                   key = "2",
                   value = "'VssSyncStart' operation failed: IDispatch error #8449 (0x80042301)",
                }
             ],
             message = "The Guest OS has reported an error during quiescing.
    --> The error code was: 5
    --> The error message was: 'VssSyncStart' operation failed: IDispatch error #8449 (0x80042301)
    --> ",
          }
       ],
       msg = "An error occurred while quiescing the virtual machine. See the virtual machine's event log for details."
    }
    --> Args:
    --> Arg vmid:6
    --> Arg name:"clone-temp-1286776661914351"
    --> Arg description:
    "This temporary snapshot is taken as part of the clone operation. The temporary snapshot will be deleted once the clone operation is complete."
    --> Arg memory:false
    --> Arg quiesce:true

  • The vmware.log of the virtual machine contains entries similar to:

    2010-10-10T23:02:12.050Z| vcpu-3| [msg.snapshot.quiesce.vmerr] The Guest OS has reported an error during quiescing.
    2010-10-10T23:02:12.050Z| vcpu-3| --> The error code was: 5
    2010-10-10T23:02:12.050Z| vcpu-3| --> The error message was: 'VssSyncStart' operation failed: IDispatch error #8449 (0x80042301)

Cause

This issue occurs because the I/O in the virtual machine is high and the quiescing operation is unable to flush all the data to disk, while further I/O is created.
 
This issue may also occur if you try creating a quiesced snapshot on a virtual machine which does not have free space. 
That is, if the free space on the virtual machine is 0 bytes.

Resolution

Note: It has been reported that this issue can occur after installing a third party backup agent inside the virtual machine without rebooting it. If this is the case, a reboot of the virtual machine should be tried to determine if that resolves the issue, before engaging in more advanced troubleshooting.

To resolve this issue, perform one of these options:


If you do not want to quiesce the virtual machine during the snapshot creation, there are several options. Choose one of these options, based on your environment: 

  • If you are using VCB or a backup product that relies upon the VCB framework, see Quiescing Mechanisms in the Virtual Machine Backup Guide.

    Note: vSphere 5.0 does not support VCB.

  • If you are taking the snapshot manually in ESX/ESXi 4.x or ESXi 5.0, deselect the Quiesce guest file system option in the vSphere Client when you are taking the snaphot. In ESX/ESXi 3.5, it is not possible to take quiescent snapshots from the VMware Infrastructure Client.

  • You can consider stopping the application before the backup and restarting it again using the pre-freeze and post-thaw scripts which are a feature of VMware Tools. For more/related information see the Running Customer Quiescing Scripts section of the Virtual Machine Backup Guide

  • If the snapshots are taken via the ESXi host using the vim-cmd command, set the option of quiescing to 0.

    To get a list of virtual machines and their VMID, run the command:

    # vim-cmd vmsvc/getallvms

    To set the quiescing to 0, run the command:

    # vim-cmd vmsvc/snapshot.create <vmid> [snapshotName] [snapshotDescription] [includeMemory] [quiesced]

    For example, if the virtual machine, testVM, has a VMID of 23, the command would be:

    # vim-cmd vmsvc/snapshot.create 23 "SnapName" "Snap Description" 0 0

  • If the snapshots are taken via the ESX host terminal using the vmware-cmd command, set the option of quiescing to 0.

    To set quiescing to 0, run the command:

    # vmware-cmd <cfg> createsnapshot <name> <description> <quiesce> <memory>

    For example:

    # vmware-cmd /vmfs/volumes/4adecc3a-62b367e8-5b15-001a4be960e0/VMname/VMname.vmx createsnapshot "Snap Name" "Snap Description" 0 0

  • If you are using a 3rd party backup product that does not allow you to configure for non-quiescent snapshots, remove the VSS component from the Windows guest operating system, provided as part of VMware Tools. When a quiescent snapshot is requested, VMware Tools does not find and utilize the VSS driver and the attempts to quiesce the filesystem are not made. The/var/log/vmware/hostd.logfile reports this incident, but the snapshot creation completes without additional errors.

    Note: This requires a reboot of the virtual machine. VMware recommends scheduling downtime before performing this action.
    1. Uninstall VMware Tools.
    2. Allow the system to reboot.
    3. Reinstall VMware Tools. Ensure to click Custom Install.
    4. Deselect VSS.

  • After the installation, you are able to take a snapshot where the quiescing operation is not performed even if specifically requested.
Notes:
  • Older versions of Windows and guests deployed prior to VMware ESX 3.5 Update 2 utilize the Sync Driver, instead of VSS, for quiescent snapshot requests.
  • When using the Symantec Netbackup tool with virtual machines running Microsoft Exchange, consider using the Symantec VSS provider.  For more information, see The Symantec VSS provider for VMware section of the NetBackup for VMware 7.1 Administrator's Guide.

Additional Information

Tags

cannot-create-quiesced-snapshots

See Also

Update History

09/27/2011 - Added additional cause 11/17/2011 - Added information on using Symantec VSS provider and added link to the NetBackup for VMware 7.1 Administrator's Guide.

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