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Site Recovery Manager 4.0 service does not start after upgrading to vCenter Server 4.0 Update 1

Symptoms

After upgrading to vCenter Server 4.0 Update 1, you may experience these symptoms:
  • The VMware vCenter Server service is running.
  • The VMware Site Recovery Manager service is no longer running.
  • The VMware Site Recovery Manager service cannot be started.

Resolution

Cause

The file proxy.xml maps between Site Recovery Manager (SRM) and vCenter Server. This file is updated with SRM information during the SRM installation. The upgrade to vCenter Server 4.0 Update 1 resets proxy.xml to a state where there is no mapping information. 

Note: The file proxy.xml is located at
C:\document and settings\All User\VMware\VMware VirtualCenter.

Workaround

To workaround the issue, you must repair the VMware vCenter Site Recovery Manager service.
 
To repair the VMware vCenter Site Recovery Manager service:
  1. Log into the Site Recovery Manager server.
  2. Click Start > Settings > Control Panel > Add/Remove Programs.
  3. Navigate the list and identify VMware vCenter Site Recovery Manager.
  4. Click Change > Repair Maintenance.
  5. Follow the repair wizard. 

    Note: You need to supply the original setup information (such as DSN, accounts, and passwords).
     
  6. When the repair wizard completes, click Start > Run, type services.msc, and click OK.
  7. Double-click the VMware vCenter Site Recovery Manager service and click the Start button. Ensure that the service starts and remains running.

Additional Information

You may be required to restart the SRM services to identify changes in licensing between SRM and vCenter Server. When you complete the workaround and the SRM service is started successfully, the licenses change from an SRM-specific license to a license supported by vCenter Server 4.0 Update 1 environments.

Request a Product Feature

To request a new product feature or to provide feedback on a VMware product, please visit the Request a Product Feature page.

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