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VMware Data Recovery backups fail with the error: failed, error -2241 (Catalog File invalid/damaged) (1015901)
Symptoms
You are experiencing these issues with VMware Data Recovery (VDR):
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Cannot perform the backup
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Backup fails
-
You see the error:
failed, error -2241 (Catalog File invalid/damaged)
Cause
This issue occurs if the VDR catalog files are corrupt.
Resolution
To resolve the issue:
- Recreate the catalog files:
- Verify that there are no operations running on the appliance.
- Stop the datarecovery service. See Restarting the datarecovery service on a VMware Data Recovery appliance (1036768)
service datarecovery stop
- Delete the following files in the dedupe store mount point:
- /{dedupe mount point}/VMwareDataRecovery/BackupStore.cat
- /{dedupe mount point}/VMwareDataRecovery/BackupStore.cat.bak
Note: The restore points are temporarily deleted.
- Start the datarecovery service. A restart of the VDR virtual machine will similarly restart the service.
service datarecovery start
- Run an integrity check on the destination directory to recreate the catalog files. The integrity check rebuilds the BackupStore.cat files, and repopulate VDR with all restore points.
Note: The integrity check fails because the catalog files have just been deleted. This is an expected behavior. However, the catalog files are created in the background, which might take a long time. You can monitor the rebuilding process by running this command from the VDR command line:
watch -n1 -d "ls -lt /{dedupe mount point}/VMwareDataRecovery/".
If you cannot observe any progress, it is most likely due to the re-catalogue process not starting. This may be caused due to locks on the deduplication store. For more information, see VMware Data Recovery Integrity Check fails with the error: Trouble reading from destination volume, error -2241 (1018060).
- Ensure that the VDR appliance does not have any hot-added vDisks from other virtual machines attached to it. To verify this, click Edit Settings in the VDR appliance.
- Upgrade to the latest version of VDR. For more information, see VMware Data Recovery Documentation.
Additional Information
Tags
See Also
- VMware Data Recovery Integrity Check fails with the error: Trouble reading from destination volume, error -2241
- Troubleshooting VMware Data Recovery restore failures
- VMware Data Recovery のバックアップがerror -2241(Catalog File invalid/damaged)というメッセージが出力されて失敗する
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