Knowledge Base

The VMware Knowledge Base provides support solutions, error messages and troubleshooting guides
 
Search the VMware Knowledge Base (KB)   View by Article ID
 

Deploying a new virtual machine from a template fails with the error: Invalid configuration for device "1" (1001416)

Details

  • Cannot deploy a new virtual machine from a template
  • Cloning a Virtual Machine fails.
  • You see the error:

    Invalid configuration for device "1"

Solution

This issue can happen if the virtual machine used to create the template has either a floppy diskette drive or CD-ROM drive connected to it.
 
To ensure the template deploy is successful, remove any floppy diskette drives or CD-ROM drives from the configuration.
 
To remove floppy diskette drives or CD-ROM drives:
  1. Right-click the template in the inventory pane and click Convert to Virtual Machine.
  2. Right-click the virtual machine in the inventory pane and click Edit Settings.
  3. Remove any floppy diskette drives or CD-ROM drives from the configuration.
  4. Right-click the virtual machine in the inventory pane and click Convert to Template.

Tags

deploy-template  deploy-template-fails cloning-virtual-machine-fails

Update History

04/12/2011 - Added vCenter Server 4.x to Products

Request a Product Feature

To request a new product feature or to provide feedback on a VMware product, please visit the Request a Product Feature page.

Feedback

  • 7 Ratings

Did this article help you?
This article resolved my issue.
This article did not resolve my issue.
This article helped but additional information was required to resolve my issue.
What can we do to improve this information? (4000 or fewer characters)
  • 7 Ratings
Actions
KB: