Knowledge Base

The VMware Knowledge Base provides support solutions, error messages and troubleshooting guides
 
Search the VMware Knowledge Base (KB)   View by Article ID
 

esxupdate -l Query Shows Missing Packages and Wrong or Duplicate Package Versions (1000760)

Details

After upgrading an ESX Server 3.0.0 system to ESX Server 3.0.1, esxupdate -l query shows the following missing packages and wrong or duplicate package versions in the output:

Installed software bundles:
------ Name ------ --- Install Date --- --- Summary ---
3.0.0-27701 20:03:46 05/25/07
3.0.1-32039 21:06:21 05/25/07 Full 3.0.1 release of VMware ESX Server

Missing packages:
VMware-esx-drivers-scsi-aacraid-1.1.5-27701
VMware-esx-drivers-scsi-lpfcdd-v7xx-7.1.14-27701
VMware-esx-drivers-scsi-mptscsi-2.5.16-27701
VMware-esx-drivers-scsi-qla2200-v7xx-7.4.0-27701
VMware-esx-drivers-scsi-qla2300-v7xx-7.4.0-27701

Wrong or duplicate package versions:
kernel-source-2.4.21-37.0.2.EL.27701 (duplicate of 2.4.21-37.0.2.EL.32039)

After upgrading an ESX Server 3.0.0 system to ESX Server 3.0.2, esxupdate -l query shows the following missing packages in the output:

------ Name ------ --- Install Date --- --- Summary ---
3.0.0-27701 19:57:30 08/13/07
3.0.2-52542 12:51:24 08/14/07 Full 3.0.2 release of VMware ESX Server

New packages:
LGTOaama-5.1.2-1
LGTOaamvm-5.1.2-1
VMware-vpxa-2.0.1-33643

Missing packages:
VMware-esx-drivers-net-s2io-1.7.6-27701
VMware-esx-drivers-scsi-aacraid-1.1.5-27701
VMware-esx-drivers-scsi-lpfcdd-v7xx-7.1.14-27701
VMware-esx-drivers-scsi-mptscsi-2.5.16-27701
VMware-esx-drivers-scsi-qla2200-v7xx-7.4.0-27701
VMware-esx-drivers-scsi-qla2300-v7xx-7.4.0-27701
vmware-hwdata-legacy-1.00-6vmw

After upgrading an ESX Server 3.0.2 system to ESX Server 3.5.0, esxupdate -l query shows the following confusing output:

Installed software bundles:
------ Name ------ --- Install Date --- --- Summary ---
3.5.0-58399 22:58:38 09/24/07 ESX 3.0.x to 3.5.0-58399 upgrade

Wrong or duplicate package versions:
xinetd-2.3.12-6.3E.2    (should be 2.3.12-6.3E.2)
findutils-4.1.7-9.1     (should be 4.1.7-9.1)
libxml-1.8.17-9.2       (should be 1.8.17-9.2)
kernel-utils-2.4-8.37.15     (should be 2.4-8.37.15)
perl-5.8.0-94.EL3       (should be 5.8.0-94.EL3)
vim-minimal-6.3.046-0.30E.4     (should be 6.3.046-0.30E.4)
glib-1.2.10-11.1       (should be 1.2.10-11.1)
dhclient-3.0.1-10_EL3     (should be 3.0.1-10_EL3)
make-3.79.1-17.1     (should be 3.79.1-17.1)
vim-common-6.3.046-0.30E.4     (should be 6.3.046-0.30E.4)
tcpdump-3.7.2-7.E3.5     (should be 3.7.2-7.E3.5)

Solution

It is normal to see the above packages listed as missing, or wrong or duplicate in a host upgraded from ESX Server 3.0.0 to 3.0.1 or 3.0.2.
 
This behavior is also expected for an ESX Server 3.0.2 to 3.5.0 upgrade. There are no missing packages or packages with wrong versions. The output error is a known bug.
 
In ESX Server 3.0.1, the following driver packages have been replaced by an updated version:
 
ESX 3.0.0 Package ESX 3.0.1 Replacement Package
VMware-esx-drivers-scsi-aacraid-1.1.5-27701 VMware-esx-drivers-scsi-aacraid_esx30-1.1.5.1vmw-32039
VMware-esx-drivers-scsi-lpfcdd-v7xx-7.1.14-27701 VMware-esx-drivers-scsi-lpfcdd-v732-7.3.2.2_1vmw-42368
VMware-esx-drivers-scsi-mptscsi-2.5.16-27701 VMware-esx-drivers-scsi-mptscsi_2xx-2.6.34.1vmw-32039
VMware-esx-drivers-scsi-qla2200-v7xx-7.4.0-27701 VMware-esx-drivers-scsi-qla2200-v7.07-7.7.4.1vmw-32039
VMware-esx-drivers-scsi-qla2300-v7xx-7.4.0-27701 VMware-esx-drivers-scsi-qla2300-v7.07-7.7.4.1vmw-32039
 
As a result of the package replacement, esxupdate reports the packages as being missing.
 
The wrong or duplicate reporting of package kernel-source-2.4.21-37.0.2.EL.27701 is benign, and can be safely ignored. ESX Server 3.0.1 is shipped with a newer kernel source RPM package, so both kernel source packages co-exist on the system.
 
 

Keywords

esxupdate, missing, duplicate, wrong, upgrade

Request a Product Feature

To request a new product feature or to provide feedback on a VMware product, please visit the Request a Product Feature page.

Feedback

  • 0 Ratings

Did this article help you?
This article resolved my issue.
This article did not resolve my issue.
This article helped but additional information was required to resolve my issue.
What can we do to improve this information? (4000 or fewer characters)
  • 0 Ratings
Actions
KB: