Knowledge Base

The VMware Knowledge Base provides support solutions, error messages and troubleshooting guides
 
Search the VMware Knowledge Base (KB)   View by Article ID
 

VMware Security Patches Upgrade Guide (2019941)

Details

VMware has made available patches and releases to address critical security issues for several products including ESX, ESXi, Workstation, and Player. The following table provides information on these security patches and any actions you should take.

VMware recommends that customers install all security patches to maximize the protection that VMware provides. For a list of all security patches VMware provides for ESX/ESXi 3.5 and later, see Knowledge Base article 2020972, which also provides instructions for installing the patches.

Solution



Starting Point
Product Version Required Action Security Patch Needed
ESXi 5.5 5.5 See Knowledge Based Article 2076665 before applying either of these patches. Apply security patch available at http://www.vmware.com/patchmgr/
download.portal
under ESXi550-201404401-SG or ESXi550-201404420-SG.
ESXi 5.1 5.1 No additional steps needed. Apply security patch available at http://www.vmware.com/patchmgr/
download.portal
under ESXi510-201401101-SG, ESXi510-201401102-SG, and ESXi510-201401103-SG.
ESXi 5.0
5.0 and any patch or update releases before July 12, 2012
No additional steps needed.
Apply security patch available at http://www.vmware.com/patchmgr/
download.portal
under ESXi500-201308101-SG.
ESX/ESXi 4.1
4.1 U2 and any subsequent patch releases before June 14, 2012
No additional steps needed.
Apply security patch available at http://www.vmware.com/patchmgr/
download.portal
under ESX410-201312401-SG and ESX410-201312403-SG (for ESX) or ESXi410-201312401-SG (for ESXi).
4.1, 4.1 U1, and any patch releases before 4.1 U2
Update to 4.1 U2, available at http://www.vmware.com/patchmgr/
download.portal
under Build 502767 dated October 27, 2011.
Apply security patch available at http://www.vmware.com/patchmgr/
download.portal
under ESX410-201312401-SG and ESX410-201312403-SG (for ESX) or ESXi410-201312401-SG (for ESXi).
ESX/ESXi 4.0
4.0 U4 and any subsequent patch releases before June 14, 2012
No additional steps needed.
Apply security patch available at http://www.vmware.com/patchmgr/
download.portal
under ESX400-201310401-SG and ESX400-201310402-SG (for ESX) or ESXi400-201310401-SG (for ESXi).
4.0, 4.0 U1-U3, and any patch releases before 4.0 U4
Update to 4.0 U4 available at http://www.vmware.com/patchmgr/
download.portal
under Build 504850 dated November 17, 2011.
Apply security patch available at http://www.vmware.com/patchmgr/
download.portal
under ESX400-201310401-SG and ESX400-201310402-SG (for ESX) or ESXi400-201310401-SG (for ESXi).
ESX/ESXi 3.5
June 2011 3.5 U5 roll-up release and any subsequent patch releases before June 14, 2012
No additional steps needed.
Apply security patch available at http://www.vmware.com/patchmgr/
download.portal
under Bulletin ESX350-201302401-SG (for ESX) or ESXe350-201302401-I-SG and ESXe350-201302403-C-SG (for ESXi).
 
3.5, 3.5 U1-U5, and any patch releases before the June 2011 3.5 U5 roll-up release
Update to the June 2011 3.5 U5 roll-up release available at http://www.vmware.com/patchmgr/download.portal under Build 391406 dated June 2, 2011.
Apply security patch available at http://www.vmware.com/patchmgr/
download.portal
under Bulletin ESX350-201302401-SG (for ESX) or ESXe350-201302401-I-SG and ESXe350-201302403-C-SG (for ESXi).
Workstation 8.0.0 or higher
Not applicable.
7.1.x or lower
Not applicable.
Fusion 4.0 or higher Upgrade to Fusion 4.1.x available at https://my.vmware.com/web/vmware/info/slug/
desktop_end_user_computing/
vmware_fusion/4_0
.
Not applicable.
Player 4.0.0 or higher
Not applicable.
3.1.x or older
Not applicable.


Request a Product Feature

To request a new product feature or to provide feedback on a VMware product, please visit the Request a Product Feature page.

Feedback

  • 4 Ratings

Did this article help you?
This article resolved my issue.
This article did not resolve my issue.
This article helped but additional information was required to resolve my issue.
What can we do to improve this information? (4000 or fewer characters)
  • 4 Ratings
Actions
KB: